Microsoft Edge - All websites Blocked with "Site not Secure"

This one has me beaten and I've searched around for ages for a solution.

Basically, I cannot access any websites whatsoever through Microsoft Edge, yet I can with no issues using Firefox.

The error I get is "Site not Secure. Error Code = 0".

There cannot be an issue with the website as this appears whether I am trying to access Google, MSN anything! It must be a local issue with the settings on the laptop or on Edge. The laptop is running on Windows 10 and has the latest updates installed.

Just to rule out the time/date response, the date and time are correct, and they are set automatically!

Hello Karl-Mark,

What solutions have you tried? Have you tried doing a repair?

If not, this link will help guide you on doing one.
https://support.microsoft.com/en-us/help/402356...

If those solutions do not work, leave a comment and we can try something else. I hope this helps you!

4 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Which Antivirus utility are you using?

Give this a try first...

Open Start > Settings > Apps > Apps & features
Scroll down to Microsoft Edge
Select it
Click Advanced options
Click Repair

Restart

If repair does not work, try performing a Reset.

Check the Store for updates

Do you have IBM Trusteer Rapport installed? If so, you likely need to configure it.

To disable Rapport's Early Browser Protection:
1. Open Rapport's Console by choosing - Start Menu > Programs > Trusteer Endpoint Protection > Trusteer Endpoint Protection Console
2. Advance to the next page by clicking on the green arrow at the bottom-right.
3. Under 'Security Policy' at the top left corner, click on 'Edit Policy'.
4. Enter the letters as they are shown in the image and click OK.
5. Locate 'Early Browser Protection' and select 'Never' in the drop-down menu.
6. Click 'Save' and reboot your computer.
7. Check if the issue is resolved.

or

Reinstall Edge

a. Navigate to the location:

C:\Users\%username%\AppData\Local\Packages\Microsoft.MicrosoftEdge_8wekyb3d8bbwe

b. Delete everything in this folder.

c. Type Windows Powershell in search box.

d. Right click on Windows Powershell and select Run as administrator.

e. Copy and paste the following command.

Get-AppXPackage -AllUsers -Name Microsoft.MicrosoftEdge | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml" –Verbose}


Reset Edge Manually:
Open Start, type: powershell
Right click PowerShell then click Run as administrator

At the prompt, type:

Get-AppXPackage -AllUsers -Name Microsoft.MicrosoftEdge | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register “$($_.InstallLocation)\AppXManifest.xml” -Verbose}

Hit Enter

When complete, exit PowerShell, restart your computer then check if Edge is working again.

Still not working? Try performing a repair upgrade:

http://answers.microsoft.com/en-us/insider/wiki...
Best regards,
Andre Da Costa
Independent Advisor for Directly

5 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated April 16, 2021 Views 21,515 Applies to: