Microsoft Edge not opening or working

Recently, shortly after I upgraded to Windows 10, my Microsoft Edge is no longer able to open. I have tried clicking on the Edge button on the taskbar and I get no response. The Microsoft Edge icon in the start menu appears to be grayed out, and when I click on it from the Start menu the Microsoft Store opens for some reason. Is there any way to fix this? I have already tried running the system file checker (sfc /scannow) but this did not resolve my problem or detect any "integrity violations". 

I have already followed the suggestions in this thread

https://answers.microsoft.com/en-us/insider/forum/insider_wintp-insider_desktop/start-button-is-not-working-in-windows-10/af20e8c8-1783-463f-8fd1-1cbfd8a80d63

to no avail. When I type the command into the PowerShell, the console pauses indefinitely and nothing happens.

How can I reinstall or re-initialize Microsoft Edge to get it to start working again? I appreciate any assistance on this topic. Thanks.


* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi Ramy,

Thank you for posting your query in Microsoft Community.

We would be glad to help you with the issue you are facing today. I understand the difficulty with the problem.

Method: 1

I suggest you to Run the Network adapter troubleshooter and see if it helps.

  1. Press Windows logo open the search box.
  2.  Type troubleshooting, hit enter.
  3. Now click Network and Internet.
  4. Then click Network Adapter.

Method: 2

To make Microsoft Edge a faster, smoother browsing experience, it was designed to use the latest technologies. If the website you are trying to view uses older technologies, such as certain types of frames or ActiveX controls, it won’t display correctly in Edge.

As you have performed ‘sfc /scannow’, I suggest you to clear the browsing history and check if it helps.

  1. Click on the three dots on the top right corner of the browser and click on the settings option.
  2. Scroll down and you get a button choose what to clear under the clear browser data option.
  3. Click this option and you can selectively clear the cache on your browser. You can choose from browsing history, cookies, cached files, delete history etc...

If the issue still persists, you may also try to check the issue in In Private window, by clicking on the three dots and select New in Private window.

Also refer to the below link.

http://windows.microsoft.com/en-us/windows-10/edge-privacy-faq

 

Hope this helps in resolving the issue. If issue persists, do get back to us. We will be happy to assist you.

 

Thank you.

 

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I ran the Network adapter troubleshooter and it said that "it could not identify the problem," in other words it did not find any problems. 

My issue is not that webpages are not displaying correctly in Edge. My issue is that the program itself will not open. I tried clearing my web cache from Internet Options and it did not help. As I said I need some way to restore, reinstall or reinitialize the Edge Browser in windows because the Edge icon is not working and the program does not open from the taskbar or the start menu. Again, any help is appreciated.

8 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I am having the exact same problem.  Switched my browser back to Internet IE to access the Internet but would like to get MS Edge working.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

5 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I have a similar problem.  When I click on Microsoft Edge it boots up for about 2 seconds and before I can move the cursor to enter my search data  Yahoo takes over the homepage.  I've changed the settings to try to make Edge my primary browser, but I can't seem to do so.   It seems like Yahoo is overriding Edge.  I don't know why this is happening, but it  is very frustrating.  What can I do?

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I have a similar problem.  When I click on Microsoft Edge it boots up for about 2 seconds and before I can move the cursor to enter my search data  Yahoo takes over the homepage.  I've changed the settings to try to make Edge my primary browser, but I can't seem to do so.   It seems like Yahoo is overriding Edge.  I don't know why this is happening, but it  is very frustrating.  What can I do?
You problem is completely different from mine.  Microsoft Edge was not working at all for me.  It appears that you have malware insisting that you use Yahoo.  You should post this as a new thread.  That would give you a better chance of someone giving you a solution.  Also, you could check Microsoft's knowledge base and check at the Yahoo site for a solution to your problem.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I tried steps 1 and 2 and still cannot get my Microsoft Edge Icon on my taskbar to open?

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Thanks... I'll give it a try

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 As many are reporting, Edge is now opening for a quick couple of seconds. 

Please send me correction.

Thank you,

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 As many are reporting, Edge is now opening for a quick couple of seconds. 

Please send me correction.

Thank you,

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated October 27, 2020 Views 8,387 Applies to:

Related Forums