Block or allow pop-ups in Microsoft Edge (Windows 10)

I’m ashamed to say how many HOURS I spent on finding this solution.  I couldn't find it with a Bing search or in the Microsoft Support site.  I started investigating related results, and discovered the following fix while looking into the "Block pop-ups in Microsoft Edge" help screen in Microsoft Edge Support (which apparently no longer applies to Win10, BTW).

  1. Right-click on the Windows icon (lower-left corner of the screen), then click on Settings.
  2. Type "pop" or "block" into the search box on the window that comes up, and select "Block or allow pop-ups" from the suggested entries.
  3. Internet Properties window comes up, with the Privacy tab selected.  Make sure the "Turn on Pop-Up Blocker" checkbox is checked, then click on the Settings button
  4. Pop-Up Blocker Settings window comes up.  Add [in the "Address of website to allow" box] the URL address of the website for which you want to allow pop-ups, and click on the Add button (add more addresses if you want, in the same manner).
  5. Click on Close to apply the changes and close the window.
  6. Click on OK in the Internet Properties window to apply the changes and close the window.

P.S. - I should've made the above-listed title more descriptive, like "Block pop-ups as default, but allow on specific websites (Microsoft Edge, Windows 10)."  Simply blocking all pop-ups, or not blocking all pop-ups, is apparently the way it used to work.  I don't know when MS [finally] fixed it, but based on what I could find, it wasn't that long ago.

 
 

Discussion Info


Last updated October 19, 2020 Views 28,477 Applies to:

Related Forums