Microsoft Band UV Sensor does not seem to work

My friend first told me about the sensor not working over a month ago, but I didn't try it until today.  I held my band directly under the sun and activated the UV sensor, but I kept getting "No UV detected" message.  Is this a known issue?

Thanks, John

 

Question Info


Last updated April 27, 2018 Views 1,536 Applies to:
Answer
Answer

Hello JHinOC

Thanks for reaching out to us.  That is odd that you are not getting a UV reading in sunlight.

Do you note any difference between being inside and outside?  Remember that glass will likely block any UV.  Are you using a screen protector that may be covering the UV sensor?  You can review operations of the UV Tile Here.

Do ensure that the Health app and Band are fully up to date.

Best regards

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Answer

Hello NTM15

I would like you to do a full process uninstall / reinstall.

Manually sync any data from the Band (via the Health app or Desktop Sync app)
Unregister your Band from the Health app
Unpair your Band from your phone
Delete the Health app from the phone and the Sync app from PC
Restart phone and PC
Reset your Microsoft Band
Install the Health app and Sync app for PC from the Store
Proceed with setting up Band again

Let us know what your results are.

Best regards 

 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.