Kein AC3-Ton über WMP bei Wiedergabe von mit DVBViewer aufgenommenen .ts-Videos.

Hallo,

ich benutze Windows 7 Prof. 64 Bit, WMP 12 zur Wiedergabe selbst aufgenommener Videos im Transportstream-Format (.ts).

Bei der Wiedergabe von Videos mit AC3-Ton erfolgt keine Audiowiedergabe.

Bei Wiedergabe über Media Plaer Classic ist alles ok.

Was kann ich tun, um über WMP 12 AC3-Ton zu hören?

 

Informationen zur Frage


Letzte Aktualisierung am 15 Dezember, 2018 Aufrufe 2.629 Gilt für:
Antwort
Antwort

Ich habe in der Zwischenzeit etwas probiert und folgendes herausgefunden:

Mit dem Programm "tsMuxer R" von Format  .ts in das Format .m2ts gewandelte Videos mit AC3-Ton lassen sich im WMP 12 mit Ton abspielen.

Auch wenn ich als Zielformat wieder eine .ts-Datei erzeuge, läßt sich diese dann abspielen.

Aber diese neu erzeugten haben nun beim Abspielen mit dem Media Player Classic keinen AC3-Ton. Ich kann mir das nicht erklären.

Ich bin momentan nicht so tief in der Materie drin, um das aus der Lameng beantworten zu können, tippe aber darauf, dass da entweder fehlerhafte Filter an Hand ihrer Merrit-Werte in die DirectShow-Filterkette eingeklinkt werden und die empfangenen Daten nicht korrekt weiterreichen. Oder die Filter benutzen anderen "Pins" zum Abgreifen der Audio- und Video-Datenströme.   

PS: Ich habe "ffdshow" installiert, konnte aber keine Wirkung feststellen. Wie kann ich denn WMP 12 dazu bewegen, die Video- oder Audiofilter von "ffdshow" zu benutzen?

Schau mal bei [1] hat Matthias Berke eine Kurzanleitung verfasst - hab das aber nie probiert. Unter [2, 3] findest Du noch ältere Diskussionen rund um das Thema DirectShow-Filter - vielleicht hilft es noch weiter.

Bevor Du allerdings "wild" rumexperimentierst und alles mögliche installierst, lies dir ggf. mal in meinem Blog-Beitrag unter [4] den Abschnitt "Katzenjammer nach der Codec-Sause" durch. Aus diesem Grund hatte ich hier lediglich ffdshow erwähnt - welches sich wohl am "zivilsten" verhält. Unter [5] werden noch ein paar Hintergrundinfos behandelt - dort findest Du auch Verlinkungen auf Basis-Artikel rund um die ganze Thematik.

Ich hab's bisher nicht getestet, aber die Fundstelle unter [6] klingt irgendwie recht vielversprechend. Tipp: Vor der Installation irgendwelcher Filter würde ich eine Systemabbildsicherung anfertigen, um ggf. schnell wieder auf den alten Zustand zurückzukommen. 

Werde es vielleicht bei Gelegenheit mal näher in einer virtuellen Maschine untersuchen. Momentan fehlt mir die Zeit. 

Falls Du noch irgendwelche Erkenntnisse gewinnst, lasse es uns wissen - hilft vielleicht dem Einen oder Anderen weiter.

1: http://www.der-wmp.de/extra/codec-dsf/Kurzinstall-Anleitung_fuer_ffdshow.htm
2: http://www.vistaheads.com/forums/microsoft-public-de-windows-vista-multimedia/311174-wmp-ffdshow-wmp-asf.html
3: http://www.vistaheads.com/forums/microsoft-public-de-windows-vista-multimedia/282113-flv-und-mp4-im-vmc-wmp-abspielen.html

4: http://www.borncity.com/blog/2007/08/26/wenn-der-windows-movie-maker-rger-macht/
5: http://www.borncity.com/blog/2010/03/20/warum-spielt-vlc-videos-ab-und-der-wmp-12-nicht/
6: http://ac3filter.net/


Gruß/greetings G. Born - Blogs: http://blog.borncity.com
Blogs: http://www.borncity.com/blog /(Ger) - and - http://borncity.com/win/ (EN)

Wurde Ihr Problem dadurch behoben?

Das war leider nicht hilfreich.

Toll! Danke, dass Sie dies als Antwort markiert haben.

Wie zufrieden sind Sie mit dieser Antwort?

Vielen Dank für Ihr Feedback, es hilft uns dabei, die Website zu verbessern.

Wie zufrieden sind Sie mit dieser Antwort?

Vielen Dank für Ihr Feedback.