starbassfishing
Had this question 3
Question
starbassfishing asked on
| 1503 views

Movie Maker Unspecified error" when the program opens

I have tried to find an easy procedure to fix this.

It appears to be a very complex problem. I found this as a fix... but I can`t implement it. Everytime I try to change from read only it gets changed back to read only somehow.


""I had this problem and I just did some debugging and found the cause in my case: I had changed the folder attributes on my temporary files folder. Movie Maker 2.1 checks the attributes on startup and fails if the folder is read-only. I guess it'll also fail if the folder is missing but I haven't checked that.

This instance of the problem is easy to fix. Go to a command prompt (Start|Programs|Accessories|Command Prompt) and type

Set

followed by the Enter key

The resulting output usually contains a line like:

TEMP=C:\DOCUME~1\UserName\LOCALS~1\Temp

The stuff after the = sign is the path to the temporary files folder. You need to change directory to the parent folder of this temporary files folder (usually C:\DOCUME~1\UserName\LOCALS~1) by executing command

CD C:\DOCUME~1\UserName\LOCALS~1

followed by the Enter key

Then check that the Temp sub-folder exists using the dir command. If it doesn't already exist, create it using

MD Temp

followed by the Enter key

In my case the folder was there but the attributes included the read-only flag, so I reset the attributes by executing command

attrib -r +a -s -h Temp

followed by the Enter key

Start Movie Maker and it works.

Note: you can perform all of the above steps using Windows Explorer if you aren't using the defaults of hiding system files etc. but it's easy using the command prompt.

I can not change the attributes for the directory mentioned.

I am concerned that I might do more harm then good.

Has the casue of this problem been properly identified?

Is there a procedure that will actually work for my system?
Mouneshwar R
Found this helpful 0
Answer
Mouneshwar R replied on
Microsoft

Hi Starbassfishing,

The fix that you’ve stated is a fix for Windows movie maker in Windows XP . In the fix, you can see that it talks about Documents and Settings.
 TEMP=C:\DOCUME~1 \UserName\LOCALS~1\Temp

Here is the procedure that you can try for Windows Vista. Before you try this step, I would suggest you to create a restore point so that we can undo the changes.

How do I create a restore point manually?
http://windows.microsoft.com/en-US/windows-vista/System-Restore-frequently-asked-questions

Once you’ve created a restore point, try executing the following steps.

Restart the computer and use F8 key. Under Windows Advanced boot options select Safe mode and hit Enter.

  1. Once you login to Windows in Safe mode, Press Windows + R which open the Run box.
  2. Type in moviemk /safemode and hit Enter. This should open Movie Maker in Safe mode.
  3. Click on Tools and then click on Options. Under the General Tab, you’ll find the location of the temp folder like C:\users\administrator\appdata\local\temp.
  4. Now copy this location. Click on Start; in the start search paste the location and hit Enter.
  5. Create a new folder and name it as temp1.
  6. Now re-open Windows Movie maker; Under the General Tab, change temp to temp1. In other words, it should look like C:\users\administrator\appdata\local\temp to C:\users\administrator\appdata\local\temp1
Restart your computer back to the normal mode and then check. You should be able to open Windows Movie Maker.

Post your results back.
Mouneshwar R – Microsoft Support
-------------------------------------------------------------------------------------------------------------------
Visit our Microsoft Answers Feedback Forum and let us know what you think

[If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]