dandelion14
Had this question 4
Question
dandelion14 asked on
| 1497 views

Cannot get Windows Vista 64-bit to hibernate/sleep

When I click hibernate or sleep commands on my computer, the computer goes through the process of hibernating/sleeping (the screen turns off and I can hear the fan/laptop turnoff), however within 5 seconds of hibernating/sleeping, the computer restarts itself (it turns back on automatically).

I tried calling for assistance via the manufacture of my laptop. They tried to help me troubleshoot by setting/resetting the sleep/hibernation options under Power Options. We were unsuccessful. I also tried to look around but could not find any advice.

Has anyone else had this problem? Anyone can help? I would greatly appreciate it!
James-
Found this helpful 0
Answer
James- replied on
Microsoft
Hello dandelion14,

 Thank you for using Microsoft Windows Vista Forums.

 Have you ever been able to put your computer in a sleep/hibernate mode in the past without any problems?  Is your computer a laptop?  I have added a few steps below for troubleshooting.  Please let me know if this has helped or if you are still having any problems.

 USB Devices
A slight move of your mouse, a tap on the keyboard, or detection of a wireless mouse’s presence could all wake up a sleeping Vista. Fortunately the fix is easy:
  1. Go to Start, Control Panel, Device Manager;
  2. Click on Keyboards or Mice and Other Pointing Devices;
  3. Right click on your device and go to Properties;
  4. Go to the Power Managerment tab;
  5. Remove the check mark next to “Allow this device to wake the computer.”

Some people may prefer to use the keyboard to wake up a PC, which is convenient too.

Internet Time Synchronization

If your computer wakes up at the exact same time, check your time setting:

  1. Start, Control Panel, Date and Time;
  2. Internet Time;
  3. Change Settings;
  4. Uncheck “Synchronize with an Internet time server.”

Personally I think this can be a very useful feature, especially if correct time is important in whatever you’re doing. But for most people it probably doesn’t matter.

Disk Defragmentation Schedule

Scheduled disk defragmentation can wake up a computer in sleep mode as well. To turn it off, or change the schedule:

  1. Start;
  2. All Programs;
  3. Accessories;
  4. System Tools;
  5. Disk Defragmenter;
  6. Uncheck “Run on a schedule (recommended);”
  7. You can also leave the feature on but change it to once a month at a more convenient time.

 

Wake-On-LAN (WOL)

Apparently Vista is configured to enable a feature called “Wake-on-LAN.” It automatically wakes up to check network status or when there is network traffic. To disable WOL, follow these steps:

  1. Go to Start, then Control Panel;

  2. Click on Device Manager

  3. Click on the “+” sign next to the Network adapters, you should see a list of installed adapters;
  4. Right click one of them, and select Properties

  5. On the popup window, select the Power Management tab
  6. Uncheck the box next to the option “Allow this device to wake the computer”

  7. Click OK and repeat the above steps for other adapters, if any;
  8. You are done. Your computer will now have a good night’s sleep.

Note that if you prefer to use this feature, for remote access, for example, you may have to experiment with your Bios settings and jumper configuration to allow WOL and in the mean time, fix the random waking up problem.


James Microsoft Answers Support Engineer Visit our Microsoft Answers Feedback Forum and let us know what you think.
Hatrickwah
Found this helpful 0
Hatrickwah replied on
dendelion14, do you have network sharing enabled on your machine? I had a similar problem with my machine since I moved and bought an Xbox360 that I comingle with my shares on my computer. What I discovered, via searching the net quite a bit, is that if you have sharing, more specfically media shareing enabled, the system will not go to sleep. I had to go into power management, select my choice, then click on advanced setting. Under advanced settings, you first have to click that button that allows you to make changes. Once you do that scroll through the options. Near the bottom of the list is one related to media sharing, "do not sleep while sharing" or something (sorry, I'm at work on an XP box, not Vista at the moment). Under that final box you can change the selection to enable the computer to sleep. Give this a try, it worked for me. If it's confusing let me know, when I'm home tonight I can look up the specfic information you would need.
Bouncer2012
Found this helpful 0
Bouncer2012 replied on

Reply

 @dendelion14, You saved me much research. Thank you. The media sharing keeps the computer from sleeping if turned on. Once I turned it off it went right to sleep .


I am surprised that media sharing would keep the computer awake. Maybe there is a power setting or something to disable it from keeping the computer awake.

RhapsodyWolf
Found this helpful 0
RhapsodyWolf replied on

Reply

dendelion14, do you have network sharing enabled on your machine? I had a similar problem with my machine since I moved and bought an Xbox360 that I comingle with my shares on my computer. What I discovered, via searching the net quite a bit, is that if you have sharing, more specfically media shareing enabled, the system will not go to sleep. I had to go into power management, select my choice, then click on advanced setting. Under advanced settings, you first have to click that button that allows you to make changes. Once you do that scroll through the options. Near the bottom of the list is one related to media sharing, "do not sleep while sharing" or something (sorry, I'm at work on an XP box, not Vista at the moment). Under that final box you can change the selection to enable the computer to sleep. Give this a try, it worked for me. If it's confusing let me know, when I'm home tonight I can look up the specfic information you would need.
This.... ive had issues with my computer not sleeping lately... it seems to happen randomly.  Sometimes it seems to be due to me watching a video on a website, then later on notice my computer is not going to sleep (even after i have closed the website), only to have it hybernate after a reboot. And ive also had it simply flat-refuse to hybernate after a reboot in which the computer is not touched at all.  Seems to be fairly random when it decides not to hybernate, but i am trying out this tip (as mine was set to 'do not allow to hybernate while sharing') to see if it works.