Nizaris
Had this question 8
Question
Nizaris asked on
| 14249 views

Vista reports 00-00-00-00 as MAC address in ipconfig

When i do ipconfig /all i get tons of network adapters. The one that is active and that i use as my internet connection under MAC address it lists 00-00-00-00-00-00. Yes my network card works fine in device manager, as does my internet.

This software i'm trying to connect to however uses some kind of software MAC filtering (i can only assume), it has the client software send my MAC address to the server and unfortunately Vista x64 reports mine as 00-00 which prevents me from accessing it, it does NOT look at the packets itself afaik.

Why is vista incorrectly reporting my MAC address while my network card works fine ? How could i find out what is causing this issue if it's not a vista bug? This is apparently a widely known issue as many users with Vista can't access this software. Is this issue fixed in Win7 ? I hear XP doesn't have this bug but i don't want to downgrade !

Thank you for your time.
Sandeep Ghatuary
Found this helpful 2
Answer
Sandeep Ghatuary replied on

Hi Nizaris,


I would suggest you to check it again because, we do have “Tunnel adapter Local Area Connection” listed but with Physical Address: 00-00-00-00-00-00-00-E0.
I have checked several computers with it.
Tunnel adapter Local Area Connection is meant for IPv6 configuration.

Anyhow, to remove “Tunnel adapter Local Area Connection” and consequently the Physical Address: 00-00-00-00-00-00-00-E0 from ipconfig /all

1.    Click Start, type cmd in the “Start Search” box, right click the cmd.exe, and then click Run as Administrator.
2.    In the Command Prompt, type netsh int isa set state disabled, and press Enter.



Hope it helps!

Thanks and Regards,
Gulrez
Microsoft Answers Support Engineer
michael of impaqtum
Found this helpful 0
michael of impaqtum replied on

Reply

I have the same problem. If I execute your suggested procedure, it does not fix the problem. I get less tunnel adapters but still the 00-00-etc-E0 sequence. The cmd prompt returns C:\Windows\system32. Is this correct? What else could I do?

thanx Mike
helpwill
Found this helpful 1
helpwill replied on
Reply:

I just spent six weeks with same issue. I believe a vista update or virus did something to the reported mac address of the network card as it should not be all zeros. Could not find any way to change until I came across a post suggesting to download freeware Technitium which will overwrite the mac address in the registry. ( back up first in case of problems). I also have HP with Nvidia NIC running vista home premium. ISP eas no help. HP could not figure it out even when I told them about the physical address issue. All now working fine.

Jukin Joe
Found this helpful 0
Jukin Joe replied on

Reply

I was having this problem on both of my Vista computers, and this seems to have worked. I get a normal device MAC now, but my 2-Wire Gateway from AT&T U-verse still reports the tunnel MAC. Does this mean my gateway will take care of things when IPv6 gets fully deployed, or will I need to enable the adapter again at some time in the future?
Issken
Found this helpful 0
Issken replied on

Reply

In regards to the Tunnel adapter Local Area Connection this has something to do with IPV6.  I had tried that command on my Windows 7 system but it did not work.  Since I am on a lot of different networks i have a lot of Tunnel adapter Local Area Connection entries which cause CMD to have buffer overflow cutting off the top part of the "ipconfig /all" command that listed the MAC address.

So what I did is turn off IPV6 and rebooted my computer.  After I did that it cleared out most of theTunnel adapter Local Area Connection entries to stop CMD from having buffer overflow so I could get the MAC address for my network card.

Here is the link to turn off IPV6 in Windows Vista and Windows 7 if you need it.

How to turn off IPV6 in Windows 7 and Windows Vista

Also here is the link to my whole process in getting your MAC address with a screen shot of what you should see after you run the "ipconfig /all" command.

How to determine your computer's MAC address

Issken

Hexa Fox
Found this helpful 0
Hexa Fox replied on

Reply

Thanks I am doing a lab for school. We are without the professor so I had to figure out my problem on my own. This fixed my problem. I have yet to reboot my computer, so is this a permanent fix? Did I disable whatever adapter that was giving me the above code?