_RaFi_
Had this question 5
Question
_RaFi_ asked on
| 7221 views

Can't install hotfix Security Update for Windows (KB2416400), getting error 0x80092004

This is from my C:\Windows\Logs\CBS\CBS.log:

2010-12-16 00:50:16, Info                  CSI    2594343f20b4886a5a8e907, Version = 8.0.7600.20831, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral]) ref: ( flgs: 00000000 guid: {d16d444c-56d8-11d5-882d-0080c847b195} name: [l:156{78}]"Package_6_for_KB2416400~31bf3856ad364e35~amd64~~6.1.1.2.2416400-47_neutral_LDR" ncdata: [l:2{1}]"3") thumbprint: [l:128{64}]"f6b70048b0caeda7576433047be057f4f010eedf2b6ba17399eff071afa6fe69"

  Pin (3): flags: 0 tlc: [8ccaa8dd90baa4275d40693518b9aad1, Version = 8.0.7600.16700, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral]) ref: ( flgs: 00000000 guid: {d16d444c-56d8-11d5-882d-0080c847b195} name: [l:156{78}]"Package_6_for_KB2416400~31bf3856ad364e35~amd64~~6.1.1.2.2416400-48_neutral_GDR" ncdata: [l:2{1}]"3") thumbprint: [l:128{64}]"f6b70048b0caeda7576433047be057f4f010eedf2b6ba17399eff071afa6fe69"

  Pin (3): flags: 0 tlc: [afad88f4acc64f24e07555fbcdaea159, Version = 8.0.7600.20831, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral]) ref: ( flgs: 00000000 guid: {d16d444c-56d8-11d5-882d-0080c847b195} name: [l:156{78}]"Package_6_for_KB2416400~31bf3856ad364e35~amd64~~6.1.1.2.2416400-49_neutral_LDR" ncdata: [l:2{1}]"3") thumbprint: [l:128{64}]"f6b70048b0caeda7576433047be057f4f010eedf2b6ba17399eff071afa6fe69"

  Pin (3): flags: 0 tlc: [1c34fed4eabacecdbbe882f457f8ff69, Version = 8.0.7600.16700, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral]) ref: ( flgs: 00000000 guid: {d16d444c-56d8-11d5-882d-0080c847b195} name: [l:156{78}]"Package_6_for_KB2416400~31bf3856ad364e35~amd64~~6.1.1.2.2416400-50_neutral_GDR" ncdata: [l:2{1}]"3") thumbprint: [l:128

2010-12-16 00:50:16, Info                  CSI    {64}]"f6b70048b0caeda7576433047be057f4f010eedf2b6ba17399eff071afa6fe69"

  Pin (3): flags: 0 tlc: [4b54d05e04d5aaac1e9620dace727d8f, Version = 8.0.7600.20831, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral]) ref: ( flgs: 00000000 guid: {d16d444c-56d8-11d5-882d-0080c847b195} name: [l:156{78}]"Package_6_for_KB2416400~31bf3856ad364e35~amd64~~6.1.1.2.2416400-51_neutral_LDR" ncdata: [l:2{1}]"3") thumbprint: [l:128{64}]"f6b70048b0caeda7576433047be057f4f010eedf2b6ba17399eff071afa6fe69"

  Pin (3): flags: 0 tlc: [b90bf3509c93d499477353a06ecebfac, Version = 8.0.7600.16700, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral]) ref: ( flgs: 00000000 guid: {d16d444c-56d8-11d5-882d-0080c847b195} name: [l:156{78}]"Package_6_for_KB2416400~31bf3856ad364e35~amd64~~6.1.1.2.2416400-52_neutral_GDR" ncdata: [l:2{1}]"3") thumbprint: [l:128{64}]"f6b70048b0caeda7576433047be057f4f010eedf2b6ba17399eff071afa6fe69"

2010-12-16 00:50:16, Info                  CSI    0000074c Component change list: 

2010-12-16 00:50:16, Info                  CSI    0000074d Couldn't find the hash of component: Microsoft-Windows-IE-HTMLRendering, Version = 8.0.7600.20831, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the catalog [l:192{96}]"\SystemRoot\WinSxS\Catalogs\f6b70048b0caeda7576433047be057f4f010eedf2b6ba17399eff071afa6fe69.cat".


2010-12-16 00:50:16, Error                 CSI    0000074e@2010/12/15:23:50:16.725 (F) d:\w7rtm\base\wcp\componentstore\csd_winners.cpp(1302): Error 80092004 [Warning,Facility=FACILITY_NTSSPI,Code=8196 (0x2004)] originated in function CCSDirectTransaction::AddImplicationsToCatalogsAndVerifyComponentHashes expression: (null)

[gle=0x80004005]

2010-12-16 00:50:16, Error                 CSI    0000074f (F) 80092004 [Warning,Facility=FACILITY_NTSSPI,Code=8196 (0x2004)] #959159# from CCSDirectTransaction::PrepareForCommit(...)[gle=0x90092004]

2010-12-16 00:50:16, Error                 CSI    00000750 (F) 80092004 [Warning,Facility=FACILITY_NTSSPI,Code=8196 (0x2004)] #959158# from CCSDirectTransaction::ExamineTransaction(...)[gle=0x90092004]

2010-12-16 00:50:16, Error                 CSI    00000751 (F) 80092004 [Warning,Facility=FACILITY_NTSSPI,Code=8196 (0x2004)] #959157# from CCSDirectTransaction_IRtlTransaction::ExamineTransaction(...)[gle=0x90092004]

2010-12-16 00:50:16, Error                 CSI    00000752 (F) CRYPT_E_NOT_FOUND #958475# from Windows::COM::CPendingTransaction::IStorePendingTransaction_Analyze(...)[gle=0x80092004]

2010-12-16 00:50:16, Error                 CSI    00000753 (F) CRYPT_E_NOT_FOUND #956791# from Windows::ServicingAPI::CCSITransaction::ICSITransaction_Commit(Flags = 38 (0x00000026), pSink = NULL, disp = 0, coldpatching = FALSE)[gle=0x80092004]

2010-12-16 00:50:16, Error                 CSI    00000754 (F) CRYPT_E_NOT_FOUND #956790# 945240 us from Windows::ServicingAPI::CCSITransaction_ICSITransaction::Commit(flags = 0x00000026, pSink = NULL, disp = 0)

[gle=0x80092004]

2010-12-16 00:50:16, Error                 CBS    Exec: Failed to commit CSI transaction to resolve execution chain. [HRESULT = 0x80092004 - CRYPT_E_NOT_FOUND]

2010-12-16 00:50:16, Info                  CSI    00000755@2010/12/15:23:50:16.834 CSI Transaction @0x18e4000 destroyed

2010-12-16 00:50:16, Info                  CBS    Perf: Resolve chain complete.

2010-12-16 00:50:16, Info                  CBS    Failed to resolve execution chain. [HRESULT = 0x80092004 - CRYPT_E_NOT_FOUND]

2010-12-16 00:50:16, Error                 CBS    Failed to process single phase execution. [HRESULT = 0x80092004 - CRYPT_E_NOT_FOUND]

2010-12-16 00:50:16, Info                  CBS    WER: Generating failure report for package: Package_for_KB2416400~31bf3856ad364e35~amd64~~6.1.1.2, status: 0x80092004, failure source: Resolve, start state: Absent, target state: Installed, client id: WindowsUpdateAgent

2010-12-16 00:50:16, Info                  CBS    Failed to query DisableWerReporting flag.  Assuming not set... [HRESULT = 0x80070002 - ERROR_FILE_NOT_FOUND]

2010-12-16 00:50:16, Info                  CBS    Failed to add %windir%\winsxs\pending.xml to WER report because it is missing.  Continuing without it...

2010-12-16 00:50:16, Info                  CBS    Failed to add %windir%\winsxs\pending.xml.bad to WER report because it is missing.  Continuing without it...

2010-12-16 00:50:17, Info                  CBS    Reboot mark refs: 0

2010-12-16 00:50:17, Info                  CBS    SQM: Reporting package change for package: Package_for_KB2416400~31bf3856ad364e35~amd64~~6.1.1.2, current: Absent, pending: Default, start: Absent, applicable: Installed, target: Installed, limit: Installed, hotpatch status: StillGoing, status: 0x0, failure source: Resolve, reboot required: False, client id: WindowsUpdateAgent, initiated offline: False, execution sequence: 1281, first merged sequence: 1281

2010-12-16 00:50:17, Info                  CBS    SQM: Upload requested for report: PackageChangeBegin_Package_for_KB2416400~31bf3856ad364e35~amd64~~6.1.1.2, session id: 142859, sample type: Standard

2010-12-16 00:50:17, Info                  CBS    SQM: Ignoring upload request because the sample type is not enabled: Standard

2010-12-16 00:50:17, Info                  CBS    SQM: Reporting package change completion for package: Package_for_KB2416400~31bf3856ad364e35~amd64~~6.1.1.2, current: Absent, original: Absent, target: Installed, status: 0x80092004, failure source: Resolve, failure details: "(null)", client id: WindowsUpdateAgent, initiated offline: False, execution sequence: 1281, first merged sequence: 1281

2010-12-16 00:50:17, Info                  CBS    SQM: resolve time performance datapoint is invalid. [HRESULT = 0x80070490 - ERROR_NOT_FOUND]

2010-12-16 00:50:17, Info                  CBS    SQM: stage time performance datapoint is invalid. [HRESULT = 0x80070490 - ERROR_NOT_FOUND]

2010-12-16 00:50:17, Info                  CBS    SQM: execute time performance datapoint is invalid. [HRESULT = 0x80070490 - ERROR_NOT_FOUND]

2010-12-16 00:50:17, Info                  CBS    SQM: Upload requested for report: PackageChangeEnd_Package_for_KB2416400~31bf3856ad364e35~amd64~~6.1.1.2, session id: 142862, sample type: Standard

2010-12-16 00:50:17, Info                  CBS    SQM: Ignoring upload request because the sample type is not enabled: Standard

2010-12-16 00:50:17, Info                  CBS    Enabling LKG boot option

2010-12-16 00:50:17, Info                  CBS    Exec: End: nested restore point - complete.

2010-12-16 00:50:17, Info                  CBS    Restored system sleep block state: 0x80000000

2010-12-16 00:50:17, Info                  CBS    Exec: Processing complete.  Session: 30121138_3300984261, Package: Package_for_KB2416400~31bf3856ad364e35~amd64~~6.1.1.2 [HRESULT = 0x80092004 - CRYPT_E_NOT_FOUND]


Any ideas how to fix it?Yes, I had MSIE 9 preview, but removed it a week ago.

_RaFi_
Found this helpful 2
Answer
_RaFi_ replied on

Reply

OK, I did as you suggested:

1) uninstalled hotfix 2422556 (& reboot)

2) run Windows6.1-KB947821-v8-x64.msu (not sure if it was really needed)

3) installed Windows6.1-KB2416400-x64.msu from a downloaded copy

and it worked successfully ;-)

 

Thanks for your help!

PA Bear MS MVP
Found this helpful 0
PA Bear MS MVP replied on

Help us help you: Start by reading this "sticky" post...

What information to post in the Windows Update forum
http://social.answers.microsoft.com/Forums/en-US/vistawu/thread/1467f44b-ee27-4f7d-98d7-f1c4b35b3395

PS: You are not alone...

http://social.answers.microsoft.com/Forums/en-US/vistawu/thread/d3fe8beb-ada0-4d69-a6a8-27553690313c
 
http://social.answers.microsoft.com/Forums/en-US/vistawu/thread/3576a525-755a-4e04-b335-8c756d7dba53
 
http://social.answers.microsoft.com/Forums/en/vistawu/thread/5efff657-5d98-4c5d-b90e-743cbf1e6d0d 


~Robear Dyer (PA Bear) ~ MS MVP (IE, Mail, Security, Windows & Update Services) since 2002 ~ Disclaimer: MS MVPs neither represent nor work for Microsoft
~Robear Dyer (PA Bear)
MS MVP-Windows Client (Security, Update Services, IE & Mail) since 2002
SteveBoyce
Found this helpful 2
SteveBoyce replied on

We had this on all so far tested pc's in the company

This worked for me and it only worked with all 3 steps exactly as follows

1. uninstall hotfix 2244556 (mshtml update) which we had installed and reboot

2. run 947821 to repair the package store

3. install 2416400 from a downloaded copy and not from wu

Probably 2244556 was the problem in our case.  Running 947821 alone did not help. Equally, there are multiple possible causes of an 0x80092004 error and I did not get as far as running procmon, so this solution may well not be relevant for others.

I had also tried rebuilding the software distribution database and suchlike but this was not helpful.

 

 

_RaFi_
Found this helpful 1
_RaFi_ replied on

Reply

Are you sure that it was 2244556? Or perhaps http://support.microsoft.com/kb/2422556 ?
PA Bear MS MVP
Found this helpful 0
PA Bear MS MVP replied on

Reply

@SteveBoyce: Installing KB2422556 (not KB2244556) leaves you with a QFE-branch version of MSHTML.DLL. If all is well with the computer, the installer for KB2416400 (as offered via Windows Update) should install an updated, QFE version of MSHTML.DLL.
~Robear Dyer (PA Bear)
MS MVP-Windows Client (Security, Update Services, IE & Mail) since 2002
_RaFi_
Found this helpful 2
Answer
_RaFi_ replied on

Reply

OK, I did as you suggested:

1) uninstalled hotfix 2422556 (& reboot)

2) run Windows6.1-KB947821-v8-x64.msu (not sure if it was really needed)

3) installed Windows6.1-KB2416400-x64.msu from a downloaded copy

and it worked successfully ;-)

 

Thanks for your help!

SteveBoyce
Found this helpful 0
SteveBoyce replied on

Reply

1. Sorry for the 2422556 / 2244556 typo

2. @ PA Bear, Yes we are back on the main branch and the qfe is lost.  I did have a look inside 2416400 and yes I can see that this is what should have happened.  I suspect that the error is in the hotfix and not the main security update and this is why 947821 is necessary.  Priority for me was to get the security fix in place.

3. @_RaFi_ Thanks for feedback it worked for you too.   

PA Bear MS MVP
Found this helpful 0
PA Bear MS MVP replied on

Reply

@SteveBoyce only: Do your computers update via AU or WSUS?

If the latter, see http://blogs.technet.com/b/sus/archive/2010/12/16/update-on-a-couple-issues-we-are-seeing-related-to-detection-and-installation-of-ms10-090-kb2416400.aspx 


~Robear Dyer (PA Bear) ~ MS MVP (IE, Mail, Security, Windows & Update Services) since 2002 ~ Disclaimer: MS MVPs neither represent nor work for Microsoft
~Robear Dyer (PA Bear)
MS MVP-Windows Client (Security, Update Services, IE & Mail) since 2002