Applies to:
dbreene
Had this question 10
Question
dbreene asked on
| 13306 views

Runtime Error in Explorer.EXE

Why do I get the following message:

<!-- /* Font Definitions */ @font-face {font-family:"Cambria Math"; panose-1:2 4 5 3 5 4 6 3 2 4; mso-font-charset:1; mso-generic-font-family:roman; mso-font-format:other; mso-font-pitch:variable; mso-font-signature:0 0 0 0 0 0;} @font-face {font-family:Calibri; panose-1:2 15 5 2 2 2 4 3 2 4; mso-font-charset:0; mso-generic-font-family:swiss; mso-font-pitch:variable; mso-font-signature:-520092929 1073786111 9 0 415 0;} /* Style Definitions */ p.MsoNormal, li.MsoNormal, div.MsoNormal {mso-style-unhide:no; mso-style-qformat:yes; mso-style-parent:""; margin-top:0in; margin-right:0in; margin-bottom:10.0pt; margin-left:0in; line-height:115%; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:Calibri; mso-fareast-theme-font:minor-latin; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi;} .MsoChpDefault {mso-style-type:export-only; mso-default-props:yes; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:Calibri; mso-fareast-theme-font:minor-latin; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi;} .MsoPapDefault {mso-style-type:export-only; margin-bottom:10.0pt; line-height:115%;} @page Section1 {size:8.5in 11.0in; margin:1.0in 1.0in 1.0in 1.0in; mso-header-margin:.5in; mso-footer-margin:.5in; mso-paper-source:0;} div.Section1 {page:Section1;} -->

Windows 7 Microsoft Visual C++ Runtime Library

Runtime Error Program C:\Windows\Explorer.EXE

This application has requested the Runtime to terminate it in an unusual way.

 

Fahimulla K
Found this helpful 0
Answer
Fahimulla K replied on
Microsoft
Hi,
 

I suggest that follow the below steps:

1. Click on the following link: http://support.microsoft.com/kb/822521
2. Click the Fix this problem link.
3. Then click Run in the File Download dialog boxes, and follow the steps in the Disable Microsoft Internet Explorer Script Debugging Wizard.

Thanks and Regards:
Swati Keni- Microsoft Support
StanWalker
Found this helpful 0
StanWalker replied on

Reply

Swati,

The computer on which I am having this problem is, as shown by "Systems Properites" (Control Panel --> System)

Microsoft Windows XP
Professional
Version 2002
Service Pack 3

Dell Vostro 1000
Movile AMD Sempron(tm)
Processor 3600+
2.00 Ghz, 896 MB of Ram


The problem that dbreene reported was with Windows explorer (explorer.exe) not Internet Explorer (iexplorer.exe) and the page you referred them to has nothing to do with a problem with Windows Explorer.

When they posted their question, they did nothing but give the error message. They did not say what was leading up to the error message, what they were trying to do, etc. so I can't know if they are having the same problem - with Windows Explorer - that I am having.

However, the error message they are getting is the same as I am getting, below, except that the text in the Title Bar is different. The error message itself is the same.


Here is the error message I'm getting (this is a constant, not intermittent, problem) --

----------------------------

"Microsoft Visual C++ Runtime Library (this is the text that is in the error Window's title bar)

Runtime Error!
Program: C:\WINDOWS\Explorer.EXE

This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.
--------------------------------

The problem occurs when I try to copy folders to or from a USB storage device - a "zip drive." I have been able to use USB drives before. I have tried 3 different ones and the error occurs with all of them. I have also scanned the units and they are clean.

I have also deleted all USB devices via Hardware Manager and restarted the system, thinking that perhaps there was a driver installation problem. After restarting, the system "found" the devices and installed drivers for them. The problem is still occuring.

INDIVIDUAL FILES CAN be copied to and from the USB drive but when I try to copy A FOLDER (using Windows Explorer either by drag and drop, cut and paste, or copy and paste) the error occurs.

The data on the USB drive is readable - I ran Roxio software and "burned" the contents of the USB drive to a CD with absolutely no problem.

The problem occurs when using Windows Explorer (explorer.exe)

I recently installed "Compatibility Pack for 2007 Office System", from the file, FileFormatConverters.exe, which I downloaded from the MS site - the URL of the file was http://download.microsoft.com/download/9/2/2/9222D67F-7630-4F49-BD26-476B51517FC1/FileFormatConverters.exe and the download page was http://www.microsoft.com/downloads/en/confirmation.aspx?familyId=941b3470-3ae9-4aee-8f43-c6bb74cd1466&displayLang=en

That is the only software that has been installed on this computer in at least 3 or 4 weeks and the problem has only started in the past few days.

I downloaded the Compatibility Pack because I was sent a .doc file which my copy of the Word Viewer (I do not have MS office) could not handle. Word Viewer asked if I wanted to download a compatibility pack to handle the file and I said yes. The page at http://r.office.microsoft.com/r/rlidO12Converters?clid=1033&p1=Wd&p2=11 was opened.

I followed the instructions on that page, and subsequent pages I was taken to, and downloaded and installed the Compatibility Pack and was able to read the .doc file.


As I have been hunting for a fix to my problem with Windows Explorer, there has been mention of similar errors occurring after Office updates were installed.

I don't remember if this problem started before or after I installed the Compatibility Pack but I uninstalled the Compatibility Pack, restarted the computer, and tried to copy folders again - the problem is still happening.

I can copy and paste, drag and drop, cut and paste folders from one folder on the C: drive to another folder on the C: drive without problems, but when I try to move a folder to or from the USB drive, the error occurs.

Now, understand that I do not believe it is really a problem with the USB interface. I suspect that if I had another HDD, on this system, the problem would also occur if I tried to copy between the two HDDs. I have no proof of that, but I strongly suspect it would happen - that is, I suspect this problem has nothing to do with the fact that a USB device is being used. I think the problem lays elsewhere. For one thing, individual files can be copied but folders can't. I would suspect that if there is a USB issue here, I would not be able to copy files or folders but files can be copied.

The only "drive" I have to test this on is a USB drive so I can't confirm my suspicion.

What I do know is that I can no longer copy folders to and from my USB drives.


Do you, or anyone else reading this, have any clue as to how I can get Windows Explorer to work properly again and allow me to copy folders between the USB drives and the C: drive?


Stan

SiSwati007
Found this helpful 0
SiSwati007 replied on

Reply

hi Stan

have you been able to fix your problem?

I have exactly the same, only that I run windows 7. Have tried to restore the system to a few days ago, same problem. restore to a week ago, same problem. The funny bit is that there are folders I can copy as a whole and some others that do what you describe. USB sticks aren't the problem here.

If I copy the same folders somewhere else (HDD) for instance, no issue whatsoever.

I cannot think of anything I have installed that would create the problem, I don't have the softwares you are mentioning in your post. 

Mind blowing...

Please let me know if you've found a fix, I've been searching for a while now...

Jose

AndyMoz
Found this helpful 0
AndyMoz replied on

Reply

I am also experiencing exactly the same problem as Stan - he's described it identically to how it's affecting my PC - with Windows XP.  I've yet to try a system restore point, but will let you know how I get on.

Any update on this - can anyone advise me how to get it working again so I can drag and drop folders onto USB sticks?  I couldn't find this problem widely reported in any Google searches, so any advice would be gratefully received.

Thanks

Andrew
AndyMoz
Found this helpful 0
AndyMoz replied on

Reply

I found this error in my Windows XP event log.  Here's what it said happened:

Event Type: Information
Event Source: Winlogon
Event Category: None
Event ID: 1002
Date:  19/08/2010
Time:  21:52:11
User:  N/A
Computer: ANDREW
Description:
The shell stopped unexpectedly and Explorer.exe was restarted.

For more information, see Help and Support Center at

http://go.microsoft.com/fwlink/events.asp.

The help and suport centre link has no tips to solve the problem.

Anyone got any further ideas as a result of the above?

Cheers,

Andy

Sirous
Found this helpful 0
Sirous replied on

Reply

Hi,

I have exactly the same problem with my Windows 7.

I can copy files but when I copy folders the problem occures.

I tried to install visual c++ again and also tried to uninstall lots of programs but nothing happend.

STheodorou
Found this helpful 0
STheodorou replied on

Reply

Have the same problem. Any answer?
MaraGrace
Found this helpful 1
MaraGrace replied on

Reply

After experiencing the same problem (inability to copy certain FOLDERS to my USB drive -- copying the files from those folders individually went okay) and finding nothing much useful on the Internet (other than various users trying to narrow down symptoms; uninstalling/reinstalling Visual C++; reformatting the USB drive; uninstalling/reinstalling USB stick drivers etc.) I've found a quick workaround to the problem until Microsoft is able to offer a better solution:

 

"ZIP" THE FOLDER(S) USING A FILE ARCHIVING PROGRAM

================================================
1) Download and install a file archiving program like 7-Zip or WinRAR.

 

2) Right-click on the "corrupted" (for lack of better term) folder and find a menu selection similar to "Add to Archive.zip" (the word Archive here being a placeholder for whatever your folder name is) and click to select.

(If you have multiple "corrupted" folders like this you can put them all in a single folder and either use the Shift and/or Ctrl key(s) to highlight multiple items or click on a blank background space and draw a square around whatever folders you wish to select then right click on any of them and, as long as they selected remain selected, click on "Add to Archive.zip".)

 

COPY FOLDER(S) FROM "ZIP" ARCHIVE TO USB DRIVE

=============================================

3) Re-open the zipped file you just created in your archiving program and there should be your PREVIOUSLY "corrupted" folder(s). Simply drag and drop (or right-click copy) the folders from within the archiving program to your USB drive.

 

If it fails, you do not have the correct problem to this solution. ;)

 

I don't know if it has something to do with how windows time stamps things or what but it appears the re-creation of a brand new folder on the USB drive seems to be the hero that saves the day. An archive program is just a fast way to achieve this with larger batches of files.

 

GOOD LUCK!

KasperLindvig
Found this helpful 0
KasperLindvig replied on

Reply

I am also having the described problem.
I am running windows 7 and suspect that the problem is caused by a registry cleaner that has removed too much from the registry causing things such as explorer.exe to crash and installation of programs such as powerdvd12, SQL server 2008 and visual studio 2010 to fail at the very end of the installation. Explorer.exe only crashes for me when the folder name is one character long. Is the name of the folder longer than that, then it works perfectly. (copying to and from any drive). The error not only occurs when copying, but also when right clicking the folder. At the very moment I right click it, explorer.exe crashes with the message:  Runtime error (etc.). Does anyone from the microsoft support team have any clue as to which registry cleaner has caused this if any? I think that I tried ccleaner and regcure pro. Trying to fix the issue I did a windows repair, which didn't do anything but report to me that an error was found in dotnet 4. After the windows repair and fixing of dotnet 4 the beforementioned four errors still occured. Leading me to suspect registry errors. I am reluctant to do a reinstall, as I have lots of programs installed and doing a reinstall would take a lot of time. Fixing just these few registry errors would get me up and running without errors in a hurry. All I need to know is where to do the correction. Anyone please help.

Sincerely Kasper