RedDragon71
Had this question 6
Question
RedDragon71 asked on
| 10918 views

Vista x64 Ultimate to Windows 7 Ultimate upgrade failing.

I've been having a problem upgrading several machines in my home lab to Windows 7 Ultimate. Three of the workstations are configured as such:

Asus P5Q SE Motherboard
Intel Quad Core Q9550
4 GB OCZ RAM
Soundblaster X-Fi XtremeGamer Sound Card
EVGA 9800 GT, GTX 260 and GTX 280 Video Cards
1.5 TB Seagate Hard Drives
Liteon DVD-RW

I also have 1 workstation that has the following:

Asus P5K3 Deluxe DDR3 Motherboard
Intel Quad Core P9550
4 GB Corsair RAM
Soundblaster X-Fi XtremeGamer Sound Card
EVGA 9800 GT Video Card
1.5 TB Seagate Hard Drives
Liteon DVD-RW

All of these machines have Vista x64 Ultimate SP2 currently on them and have been running fine for months and are up to date on all patches.

My problem comes in the final phase of the upgrade where I assume the final reboot is occurring that comes back and asks you the questions like serial keys and such. Upon the reboot the system blue screens and immediatley reboots before I can even see the error code.

I have run the upgrade advisor and the only thing that appears intially is the HP Laserjet 1020 Printer, Sound Card and the Parental Controls/Ultimate Extras warning. When the actual install of Windows 7 runs it only flags the Ultimate Extras and Google Toolbar (which isn't installed but my Adobe and Realplayer products have plugins for the Google toolbar that the installer is obviously finding.)

I have done the following procedures in an effort to troubleshoot the issue:

Updated all device drivers to the latest Vista x64/Windows 7 x64 compatible drivers.
Updated the motherboard BIOS to the latest version
Deleted the HP printer device
Removed the Soundblaster completely from the system.
Removed 2 GB of RAM to have a total of 2 GB instead of 4 GB
Removed several applications to ensure virtual hardware and such isn't an issue: Daemon Tools, Nero, Adobe CS3, RealPlayer, ReadyBoost devices, HP Printer devices, G15 Keyboard software
Deleted all user profiles that weren't needed
Disabled Group Policy
Ran the install directly from the DVD as well as copying the files to the local D:\ drive to run the files locally.

Bottom line is I've been working on the workstations for days trying to get one successful upgrade to work and have come up short on every single system. All of the systems blue screen on the final reboot which is very frustrating. What's worse is the next upgrade is going to be my laptop which I expect to have a lot of "fun" with if I don't get some sort of working gameplan.

Running the install from scratch with a formatted hard drive works without a hitch and even the hardware that was flagged by the upgrade advisor works like a champ which is what really blows me away by the upgrade failures. Even using the Windows Easy Transfer method gets somewhat frustrating because it copies 11 GB of information up to my remote storage and when I go to restore the profiles it only restores approx 2.5 GB of that back after the reinstall. Since this transfer obviously doesn't include registry keys most of my apps (40+) don't function correctly after this process is completed.

Is there a location where I can find an accurate log of these failures to make this upgrade work? Installing from scatch is nice and clean but it would be nice if the upgrade process also worked so I don't have to rebuild 5-6 workstations from scratch with all the various apps that need to be reinstalled. Also, speaking from my son's perspective, each reinstall on his machine will cost him another activation of some of his software like Farcry 2 and such which gets to be a pain when you have to start calling multiple vendors to activate or re-activate software. Any help or hints are greatly appreciated. Sorry for being so long winded but I've been losing a lot of time trying to troubleshoot this install process. Thanks!

Azeez N
Found this helpful 0
Answer
Azeez N replied on
Microsoft
HiRedDragon71,


Welcome to Microsoft answers community forum!
 

I'm sure it must have taken a lot of your time to post the issue and Since you've done most of the troubleshooting steps, There were 2 actions I thought you missed :
 
1) Disabling security software temporarily

2) Removing all external connections as this could interfere with the upgrade path.
 
 I'd also suggest- Try to get one machine up and running before attempting another machine.
 
 
You may want to disable Display adapter in device manager and follow the steps below
 

To perform an inplace upgrade from Windows vista to Windows 7 follow the steps below.

Before you perform an Inplace Upgrade follow the steps below:


1.  Disable or uninstall all security software’s on the computer temporarily.

.
2.  Remove all third party CD and DVD burning software.


3.  Click on Start, in the start search box type appwiz.cpl and press enter. 


4. On the left side click on “Turn Windows feature On or Off”.


5. Uncheck the following three components and then click on Ok.


• .Net Framework 3.0
• Remote Differential Compression
• Windows DFS Replication Service


Start Inplace upgrade

Please make sure you Backup any and all important data before proceeding.

Always make sure you have the means to reinstall your programs, either through an install disk or having access to the installation files

1. Insert the Windows installation disc into your computer's DVD/CD drive. You must start Windows installation while running your existing version of Windows.

2. On the Install Windows page, click Install now.

3. On the Get important updates for installation page, we recommend getting the latest updates to help ensure a successful installation and to help protect your computer against security threats. You will need an Internet connection to get installation updates.

4. On the Type your product key for activation page, we strongly recommend that you type your 25-character product key to help avoid problems during activation.

5. On the Please read the license terms page, if you accept the license terms, click I accept the license terms.

6. On the Which type of installation do you want? page, click Upgrade to begin the upgrade. You might see a compatibility report.

7. Follow the instructions.

 
If all else fail Use the following link for the setup log files for Windows Vista. : http://support.microsoft.com/kb/927521

 
 
Hope this information helped!
Let me know of it did

Thanks and Regards:
Azeez Nadeem - Microsoft Support.
Visit our Microsoft Answers Feedback Forum http://social.answers.microsoft.com/Forums/en-US/answersfeedback/threads/  and let us know what you think.

RedDragon71
Found this helpful 0
RedDragon71 replied on

Reply

Thanks for the response Azeez,

On the security side I was running the following procedures and didn't add this to my original post since I just plain forgot to considering the amount of information I've gathered.

I run a Netscreen 5 GT as my firewall and I disable my Windows Firewall on the local workstation level.
For the upgrade process (knowing that I need Internet access for the updated installation files) I opened the Netscreen completely (Any,Any,Any) to traffic. Most of the PC's download approximately 1074 bytes of data, if I remember correctly, during this process.
I had also uninstalled my McAfee Enterprise virus and anti-spyware modules and rebooted before beginning the upgrade. This included doing a command line uninstall of the ePO agent and making sure all file folders and services for McAfee were removed in the process.

Now the part about uninstalling:
• .Net Framework 3.0
• Remote Differential Compression
• Windows DFS Replication Service

This I have not done yet. I will try this tonight on one of the workstations tonight to see what effect it has on the operations.

I have browsed through the setupact.log files and to be honest I couldn't tell by the log entries where the failure was occurring. I could see clearly where the logs recorded that they were rolling back to Vista but not exactly what the cause of the rollback was.

As an IT person that's installed practically every version of Windows back to 3.11 I've never been this baffled over an upgrade and of course being in my job position I'm going to get questions very similiar to these over the next couple months so I'd like to get a jump on the troubleshooting methods for Windows 7 if possible.

I certainly appreciate your time helping with this issue. I'll post back here tonight on the results!

Wes
RedDragon71
Found this helpful 0
RedDragon71 replied on

Reply

The advice to uninstall those services did not answer the upgrade problem. Still having issues with the upgrade process.

Also, on the workstations that I did install from scratch to test 7 itself, the supporting software for the HP CM1017 Color Laserjet doesn't install properly because of a missing UNIDRV.DLL file that it apparently needs to complete the install. (This file was apparently in Vista x64 since I didn't have this issue before). Also, the Vsphere 4 client software for VMWare does not function because of a missing DLL as well. Luckily someone on the VMWare forums found a workaround by copying a Vista file over to 7 and making a modified batch file to launch the client.

akbarms
Found this helpful 0
akbarms replied on

Reply

I understand disabling the security software.  But, doing all other stuff in your suggestion seems to NOT user friendly upgrade.  The way Microsoft advertised the upgrade is suppose to be seamless.  I had the same issue where I spent too many hours with unsuccessfull tries which suppose to be only an hour worth.  Why Microsoft did not provide a readme file telling all the stuff user needs to do so we would delay the upgrade until Microsoft makes it seamless.  The upgrade advisor is a worthless junk.  It seems like the business practice of Microsoft is like gotta type such that once you buy and unpack the CD, you can not return it.  

Not only that, your Vista running machine is screwed so you do not have an option to go back.  I had finally choose custom installation changing the boot drive to DVD and boot from CD which required me to format my C drive.  I tried without formating but did not resolved the endless loop.  I definitely will be not upgrading in the future unless the new windows is used for at least 2/3 years.  I was so upset that I am now preparing a machine to run Linux and use Star office for productivity software.

Microsoft should reimburse the money we paid for Windows 7 plus the time we spent for what found to be the frustrating and worst nightmare experience just week before the Halloween.


TexasTurbo
Found this helpful 0
TexasTurbo replied on
I had the same issue. Try removing all but one stick of RAM, set memory in BIOS to default or auto setting. Shutdown and unplug your PC, wait 5 minutes replug/restart. The 4gigs of RAM in overclocked mode boogyman still exist when installing or upgrading Vista. After that procedure, in place upgrade from Vista Ultimate 64 to Windows 7 Ultimate 64, was a breeze, in less than 90 minutes!
GLBC 1
Found this helpful 0
GLBC 1 replied on
I had the same problem. I just formatted my HDD and started again. It worked for me.
Paul Keister
Found this helpful 0
Paul Keister replied on

Reply

I'm having a very similar experience with an ASUS x64 machine.  The thing that really stings is the final message: "please download the upgrade advisor".  This after I completely uninstalled 2 version of SQL Sever, Virtual PC, and Mobil sync because of upgrade advisor warnings.  Now, the upgrade advisor shows completely clean and I'm stuck with exactly the same problem that I started with 12 hours ago.  It's going to take me at least 3 hours to reinstall evertying the upgrade advisor had a problem with.

I've upgraded 2 other machines without incident, and in those cases I simply ignored upgrade advisor warnings.  Best to forget the upgrade advisor, I'd say!

TexasTurbo may have the answer here, but I may have to bail and live with Vista.  I'm way over budget on this upgrade and I don't think I could handle another failed attempt knowing how long the upgrade process takes.