Turbo00
Had this question 27
Question
Turbo00 asked on

the RPC server is unavailable on windows 7 stand alone logon

When I try to logon to my windows 7 64bit stand alone machine, I get  the error message "the RPC server is unavailable"

It accepts the login - says welcome to windows then the error message waits a while then reboots. It has a fingerprint reader, but gives the same error when using a password. It will not start go any further then this in "safe mode" or "last know good configuration mode" or any other mode.. Did a checkdisk booting from a cd rom. Booting from a CD rom, I can see all of the files.. 

HP dv9000 4 gig ram
Stand alone - no Domain or homegroup
Windows 7 Ultimate installed since it was released
fingerprint reader installed, but I get the same error using a password 
up to date on service packs, MS Defender, AVG (free ver), Malware (free ver), Spybot (free ver)

Hoping to not have to do a re-install

  thanks in advance...

acerisftw
Found this helpful 3
Answer
acerisftw replied on

Reply

Another solution is to make sure "DHCP Client" and "RPC Endpoint Mapper" "Remote Procedure Call (RPC) Locator" "Remote Procedure Call (RPC)" are all running and set to automatic.

I hope this helps too.

SonGoKu619
Found this helpful 17
Most Helpful Reply
SonGoKu619 replied on

Reply

Okay I've got a SOLUTION!!! :D IT"S FIXED

I uninstalled Office Beta 2010 this morning and when restarted the RPC Service unavailable yadda yadda couldn't log in

Okay F8>Repair>Run CMD then Bring up regedit>File>Export (Just get the explorer open)

What I've noticed is that this "repair" state is in the virtual "X Drive" so any changes made to Registry doesn't really affect the REGEDIT of your normal System when it boots

Okay now Navigate to your System Drive (REMEMBER THAT THIS REGEDIT CMD etc. IN THE REPAIR STATE IS ALL ON A VIRTUAL X:\ DRIVE SO GET INTO YOUR NORMAL SYSTEM DRIVE)

C:\Windows\system32\config (usually C:\)

Rename the File "SYSTEM" to "SYSTEM2" or similar. (These files are your registry hive files)

There's a folder called "Regback" which seems to be regular backups of your registry, copy the "system" from there into the "config" folder

 

Restart and YOU ARE DONE :D:D:D *happy*

Okay im not such a techy "coding" user and all that and if it wasn't for u guys I wouldn't have gotten it fixed (I didn't know what to do at first so i fiddled with wat u guys said) The n00B got it fixed in 1 morning though :D:D:D:D

 

Thanks a million guys and I hope this helps u

 

Waseemulla Shariff
Found this helpful 0
Waseemulla Shariff replied on
Hi Turbo00,
 
1. Did you make any changes prior to the issue?
2. How many user accounts do you have?
 
Try the following steps and check the result.
Step 1: Perform System Restore
a. Insert the Windows DVD. Unplug all the external devices connected to the computer except keyboard and mouse.
b. Restart your computer.
c. Let the computer restart (boot) from the DVD.
d. If prompted, press any key to continue.
e. When you reach the Install Windows screen, select your preferences in the Language to install, Time and currency format, and Keyboard or input method boxes, and then click Next.
f. Do not click Install now. Instead, click Repair your computer. The System Recovery Options dialog box appears.
g. Make sure the correct operating system is selected, and then click Next.
h. After you click Next, the System Recovery Options menu appears.
i. Click System Restore. Once the System Restore completes, restart the computer.
j. Remove the DVD and restart the computer to see if the system starts fine.
 

Step 2: If you've any other user account on the computer, then try logging into it and check if the issue persists.
See Fix a corrupted user profile

Regards,
Syed - Microsoft Support.
Visit our Microsoft Answers Feedback Forum and let us know what you think.
Turbo00
Found this helpful 0
Turbo00 replied on

Reply

Thanks for the reply..  I did most of this already..

The only thing that was changed in the past month, besides updates, was the removal of Office 2010 Beta. I used the Microsoft uninstall tool to do that. I did that at least 5 days before this happened.  I had not got around to put the release version on. However that was several days before this error started to occur.

I tried a startup repair from both the hard drive and from booting from the origional DVD several times.
all tests return Error code = 0x0 (which I believe means all OK) 
Root cause found:
------------------------------
Boot status indicates that the OS booted OK

I tried to do a system restore booting from the hard disk as well as the origional DVD
at all restore points, it begins, then stops with the following error:
The instruction at 0xfb83584d referenced memory at 0x00000008. The memory could not be read.
the instruction at 0xfb8b584d, changes for example 0xfb19584d where the 5th 6th 7th and 8th characters vary by restore point. I tried every one.
The 0x00000008 I believe is pointing to the registry. Is this correct ?

I can not log in with any user account. It does the same thing. It validates and says "Welcome".. with the spinning thingey, then a big red X saying "The RPC server is unavailable"   followed by a reboot. 
I had the administrator and guest account disabled, I enabled them via a PE boot disk and blanked out all of the passwords, the do the same, appear to validate and say welcome, and the RPC error again.

Each boot, the initial user gets the RPC error
After the initial RPC error, if you use the same logon, or switch users the error is immediate "Windows Security The system cannot log you on" 

I ran the Windows Memory Diagnostic Tool both from the hard drive as well as from the origional DVD as well as from the HP BIOS. all tested good
The HP BIOS is up to date

I ran avast! bart with the only errors being cookies and such.

I ran chkdsk c: /f from a command prompt booting on the origional DVD. all was normal.

I can get to the whole hard drive structure from a PE boot disk or the origional DVD and run regedit, or replace a .dll or ???  I just do not know what to look for in the registry or what to replace !

Norton AV (yes I have Norton Ghost on here without making an image in months) came up blank. 

any other suggestions or what to look for in the registry before I just wipe it all ? All help is and would be appreciated.

 Thanks in advance...

Waseemulla Shariff
Found this helpful 0
Waseemulla Shariff replied on

Reply

Hi Turbo00,
 
By your problem description, it's understood that the issue persists even when you start the computer in safe mode.
Step 1: If you're able to start the computer in safe mode, then try starting the RPC (Remote Procedure Call) services and start the computer in clean boot
a. Click Start, type services.msc and hit enter.
b. From the list of services, double click on Remote Procedure Call services.
c. Change the startup type to Automatic and click Start.
d. Click ok to apply the changes.
 
Step 2: Restart your modem or router.
a. Remove the power cable from the modem or router.
b. After all lights on the device have gone out, wait at least 10 seconds, and then plug the modem and router back in.
c. Some modems have a battery backup that prevents the lights from going out. For this type of modem, press and quickly release the Reset button.
d. Start the computer and check the result.

Regards,
Syed - Microsoft Support.
Visit our Microsoft Answers Feedback Forum and let us know what you think.
Turbo00
Found this helpful 0
Turbo00 replied on

Reply

Syed,

      Again thank you for your attempt to resolve my problem. 

      You are correct in your first statement. The same issue persists even when you start the computer in safe mode. So the kb article is not relevent as I can not get to a GUI nor command prompt logged it to start/stop services via the GUI or the command prompt. 

    I dont believe the router on the system is of issue (there is no modem on the notebook). I have restarted the router, and most of the things I have tried I have tried with both the built in NIC on and off, the wireless g/n on and off, and all combinations of the NIC cards as well as a differant router at home and my work.  This is a notebook NOT in a domain. It is just set as the default "workgroup" and is not a member of a homegroup either.

   Any thoughts on my registry theory. where is the registry place and value to autostart this service ?  I have been able to get by not using this laptop, but toward the end of Sunmmer, I am in education, I am just going to back up the data and blow it away an start over.. 

       Thanks in advance  ....

Waseemulla Shariff
Found this helpful 0
Waseemulla Shariff replied on

Reply

Hi Turbo00,

Sorry about misunderstanding your post. If you had created a system image backup, then use the backup file to restore the entire PC.

For more information, see Restore your computer from a system image backup

Regards,
Syed - Microsoft Support.
Visit our Microsoft Answers Feedback Forum and let us know what you think.

Turbo00
Found this helpful 0
Turbo00 replied on

Reply

Syed,

        I appreciate your attempts to resolve my problem, with all due respect, am I dealing with a "bot" ? 

    How does one un-install or change a program, if one can not get past the logon screen either in safemode, GUI or commandline ? 

The past two responses require a successful logon to implement. I have built, managed, and also teach helpdesk/system support at the college level. This question went way past reading a script answer after the first response. Please read the entire problem description and what has been tried, then jump to the level of the person that you are helping. It is acknowleged that I can not log in even in safe mode, then responded to with that limitation/requirement in mind. 

   I acknowledge that multiple security software programs can cause a system to fail. The ones listed, AVG (free ver), Malwarebytes (free ver), and Spybot Search and Destroy (free ver) do very differant things. MS defender has no documentated issues with any of the others. The free versions of Malwarebytes, and Spybot, require manual intervention.  That said, I do know where in the registry to halt the startup of these progams in boot. Preventing them from starting and renaming their directories (so they are not in the correct path) effectivly should make it as if they are not running or installed (with the exception of a possible error with the system searching for them). Disabling them in this manner makes no difference. The error still occurs.

   Can anyone answer my question that I keep coming back to. Where in the registry do I find, and turn on the RPC server service, what files need to be in the system and where, and what other dependencies does this service involve or require ?? 

    Thanks again in advance...      

Waseemulla Shariff
Found this helpful 0
Waseemulla Shariff replied on

Reply

Hi Turbo00,
 
Try the following steps and check the result.
Step 1: To start the RPC service, try these steps.
a. Start the computer using Windows DVD to boot to Windows Recovery Environment (WinRE) and select command prompt.
Note: Follow Step 1 in my first post to boot the computer to WinRE.
b. Type net start RpcSs and hit enter.
c. Type exit to close the command prompt.
d. Restart the computer and check the result.
 
Step 2: Check the registry entry for the service
a. Start the computer using Windows DVD to boot to Windows Recovery Environment (WinRE) and select command prompt.
Note: Follow Step 1 in my first post to boot the computer to WinRE.
b. On the command prompt, type regedit.exe and hit enter.
c. Look for the following entries:
i. Entry for Remote Procedure Call (RPC):
Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\RpcSs
ii. Entry for Remote Procedure Call (RPC) Locator:
Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\RpcLocator
 
Important:
Set REG_DWORD value to 2 for automatic start on RpcSs
Set REG_DWORD value to 3 for manual start on RPCLocator
 
Very important: Modifying the registry incorrectly will cause serious damage to the computer. Backup the registry before you make any changes.
See Backup the registry

Regards,
Syed - Microsoft Support.
Visit our Microsoft Answers Feedback Forum and let us know what you think.
afoteygh
Found this helpful 0
afoteygh replied on

Reply

I am having the same problem.. and it came about after i used the Microsoft Tool  to remove office 2010 beta unfortunatley i am not able to find Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\RpcLocator  in my registry.. what do i do now??
Turbo00
Found this helpful 0
Turbo00 replied on

Reply

afoteygh ...  Mine was a clean install, with a full format, and has worked since the week of Win 7's release. It has been a couple of weeks, but I did uninstall Office 2010 beta, and had not got a chance to install the release version on that computer when it went south. It did however work for a few days, perhaps a week after the uninstall.  I used a Microsoft Utility I downloaded from MSDN/Technet to un-install Office 2010 beta and "clean"  the machine.  That might be the reason.. Can you boot safe mode or do a system restore ?? I can not get past the logon screen.. in any mode...  

I thought that we finally found the answer, as yesterday when I did the above instructions, I also had no RpcLocator in my registry entry. I was thinking it was a path issue that Windows 7 could not find the service to start. 

Per the instructions, the first key exists and has the right paramaters.

Booting for various PE disks, the RpcSs (net start RpcSs) is running already and the error still occures after re-boot.

I also did not see the registry key even existing for "Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\RpcLocator"

We have an almost Identical HP laptop, running 64 bit Professional instead of 64 bit Ultimate, the same model base, video, motherboard, and configuration. 
It does have the RpcLocator entry.
So looking at that registry, I copied the entry to use it in the other HP computer.
I looked at a couple of other computers and the entry for RpcLocator was the same.

Here is the entry I used/created:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RpcLocator]
"Description"="@%systemroot%\\system32\\Locator.exe,-3"
"DisplayName"="@%systemroot%\\system32\\Locator.exe,-2"
"ErrorControl"=dword:00000001
"FailureActions"=hex:84,03,00,00,00,00,00,00,00,00,00,00,03,00,00,00,14,00,00,\
  00,01,00,00,00,c0,d4,01,00,01,00,00,00,e0,93,04,00,00,00,00,00,00,00,00,00
"ImagePath"=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,\
  74,00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,4c,\
  00,6f,00,63,00,61,00,74,00,6f,00,72,00,2e,00,65,00,78,00,65,00,00,00
"ObjectName"="NT AUTHORITY\\NetworkService"
"RequiredPrivileges"=hex(7):53,00,65,00,43,00,68,00,61,00,6e,00,67,00,65,00,4e,\
  00,6f,00,74,00,69,00,66,00,79,00,50,00,72,00,69,00,76,00,69,00,6c,00,65,00,\
  67,00,65,00,00,00,00,00
"Start"=dword:00000003
"Type"=dword:00000010

 The problem is, I can not get this entry to stick in the registry of the hosed computer.
I get it in there and it is gone upon reboot (to the broken computer) and the same error comes up.
I have used a WinRE environment from a retail version of Win7 as well as an MSDN version of Windows 7.
I have tried it with a Bart PE disk with a Linux registry editor.
We have a licensed copy of Active @boot disk which pays for the Microsoft PE environment and has a registry editor.   Didn't work/stick either

I have set permissions in all environments (booting from all the PE disks) to "everybody"
I set permissions in the registry also to "everybody"
I have exported/imported  the system hive as well as all the other hives and tried to get it to stick that way.
I even exported the entire registry, put it on a USB disk and edited it on a differant computer in a different environment.

I think I (we) are close. Something obviously messed with the  RpcLocator registry key..
My problem now is,  (and I STILL CAN NOT BOOT INTO THE MACHINE ITSELF) how to get that key into the registry of the broken computer and have it stick !

I could give up and just do a clean install, but I would really like to learn what happened and how to fix it..

    Thanks in advance...

afoteygh
Found this helpful 0
afoteygh replied on

Reply

Well mine started after u used the office 2010 remover to uninstall office 2010 beta, and after restarting the machine i got this error message,, I also don't want to format my machine but looking at the way things are going .. I think i'll have to format it. II really need to use it for some work .. Luckily i have ubuntu on another partition so i've been able to backup my e-mails from Thunderbird.. I really wish there was another way of going around this problem apart from formatting!!!!
Previous Previous Page of 5 Next Next