steveblue
Had this question 13
Question
steveblue asked on
| 29213 views

chkdsk runs everytime window 7 boots

notebook running windows 7 ultimate

everytime I boot my windows 7 notebook it now runs the chkdsk, even if I let the chkdsk run through all 5 checks and then says windows starting... I get taken back to the chkdsk and the following:
One of your disks needs to be checked for consistency......

how can I stop this from running everytime i boot my notebook??

thanks
Mark L. Ferguson
Found this helpful 5
Answer
Mark L. Ferguson replied on
You probably have a corrupt entry for Error Checking in the registry. A System Restore point would probably fix that. If you want to look at the entry doing it, it's at:
 
 'autocheck' entry (value)  at: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\BootExecute

If you make a restore point, and delete this value, you will probably fix it.
Rating posts helps other users
Mark L. Ferguson MS-MVP
Rating posts helps other users
Mark L. Ferguson (former MVP)
balkiis
Found this helpful 0
balkiis replied on

Reply

I also have this problem everytime i boot my laptop it checks for the disc consistency, though there was no error if I manually run the chkdsk. If I do not skip the auto check while boot up process, it just hugs and i always have to hard boot it. I tried the above solution of clearing the BootExecute Key, but i think  it disables the auto check completely while booting(though it solves the problem as it will never appear again) but I think it is not a permanent solution.  When I checked the dirty bit of C drive through( fsutil dirty query c:) it always returns as dirty. How to reset this bit manually running the chkdsk /f also does not clear it.

Please help.

banjy
Found this helpful 0
banjy replied on

Reply

I had this problem as well, but I've now worked out what the issue on my machine was.  I had an SD card inserted in the slot during bootup that it didn't like.  Removed the card and presto, no more chkdsk.

I'm runnning Windows 7 64-bit professional.
ChrisDbrown
Found this helpful 0
ChrisDbrown replied on

Reply

There seems to be an issue with Widnows 7 and some A/V Programs. I turned off chkdsk (chkntfs command) until MS or the A/V outfits have a patch.
Npiper
Found this helpful 0
Npiper replied on

Reply

I've also been having a problem with my HP WIN7 64-bit laptop doing the same thing.  It started after I installed XP Mode and Virtual PC, but may not be related.  I cleared the Bootexecute key as described, but was wondering if MS has come out with a patch for the problem stated directly above?
jolieisanangel
Found this helpful 0
jolieisanangel replied on

Reply

I am not tech savvy so please bare with me.

I tried system restore and got this message:

Windows detected file system corruption on OS (C:). You must check disk for errors before it can be restored.

OK did nothing, so my dad checked for errors for me and none were found.

We tried to restore again and got the same message.

Please try to help in a way a complete idiot can understand. I really appreciate any help. Thank You.

TSophie
Found this helpful 2
TSophie replied on

Reply

Hi Jolie,

I had the same problem and here is the Microsoft fix that I found (and applied):

http://windows.microsoft.com/en-us/windows7/What-are-the-system-recovery-options-in-Windows-7

It worked fine for me and I am not a geek ...;-)

Good luck.

S.

kittiebella
Found this helpful 2
kittiebella replied on

if someone could email me how to fix this issue i would be greatly appreciative if so all i want to do is be able to  start  up my computer without the  CHKDSK poping up i cant even  log on to windows because of this

AndreasUlmer
Found this helpful 0
AndreasUlmer replied on

Reply

avinashgautam12
Found this helpful 0
avinashgautam12 replied on
chkntfs /x c:/d:/e: in cmd with admin rights