VS9999
Had this question 3
Question
VS9999 asked on

User account hiding in 64-bit Win7

Our install script hides an account "xxxxx" in Win7 x86 by registering it in the registry key: HKLM\Software\Microsoft\Windows NT\CurrentVersion\Winlogon\SpecialAccounts\UserList


In Win7 x64 the command to hide this account goes automatically to a different key, the one under wow6432node:

HKLM\Software\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Winlogon\SpecialAccounts\UserList

This is fine, but the account is not hidden unless manually edit the registry and add the entry at the same place in the registry as for the 32-bit OS.

I could not find a way to put this info into the registry with the installshield script (Installshield 2010) and have the account hidden.

Can anybody help please?

 

VS9999
Found this helpful 0
Answer
VS9999 replied on

Reply

Hi Fisnik,

Yes, the thread has been solved but with the InstallShield solution that actually covers a Microsoft oversight.

Thank you for your assistance. It looks like no one else had this issue.

Best regards,

VS9999

ITknowledge24
Found this helpful 0
ITknowledge24 replied on

Hello VS9999 – Welcome to Microsoft Answers Community.

Why do you want to hide an account?

 

I hope you find this information useful and if you need any further assistance,
please feel free to contact me and let me know.

I hope this information was helpful…

Have a nice day…

Best regards,
Fisnik


Itknowledge24.com
Geek
Former Microsoft MVP
Consumer Security
Microsoft Community Contributor
VS9999
Found this helpful 0
VS9999 replied on

Reply

It's the project requirement to hide an account after being created by the install script.

I think this is a Windows 7 x64 bug related to accounts security, sometimes users accounts might need to be hidden from the login screen. In this particular case the Registry Reflection does not work properly as in this scenario:

- Install script creates an account "xxxxxx"

- Install script invokes command (tried all of the following commands):

   -- reg ADD HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\SpecialAccounts\UserList /v xxxxxx /t REG_DWORD /d 0

   -- reg import xxxxxx.reg  (this is a small file with the key to hide the account)

   -- C:\windows\SysWOW64\regedit /s xxxxxx.reg

   -- C:\windows\SysWOW64\regedt32 /s xxxxxx.reg

 

All the above commands only write the registry under the ..\Wow6432Node\.. and the OS does not look at that area on startup to hide the account.

To make the things even more complicated, the above commands work fine if invoked manually from a CMD window, but not from an install script.

If I manually enter the data into the 64 bit area of the registry then the account is hidden on startup.

I think the Registry Reflection software should mirror this info into the x64 area of the registry, but it does not in this case.

 

 

ITknowledge24
Found this helpful 0
ITknowledge24 replied on

Reply

Hi VS9999:

How is the situation on your side?
Is this thread solved or NOT?

Have a nice day...

Best regards,
Fisnik
Itknowledge24.com
Geek
Former Microsoft MVP
Consumer Security
Microsoft Community Contributor
VS9999
Found this helpful 0
Answer
VS9999 replied on

Reply

Hi Fisnik,

Yes, the thread has been solved but with the InstallShield solution that actually covers a Microsoft oversight.

Thank you for your assistance. It looks like no one else had this issue.

Best regards,

VS9999