pjfarr
Had this question 1
Question
pjfarr asked on
| 136 views

Can no longer save .ini files after editing.

All of a sudden I can no longer save .ini files I modify. After making the changes in Notepad, clicking File > Save or hitting CTRL+S, now brings up the "Save As" dialog instead of just saving it as is. But even when I use "Save As" it will say I don't have permission to save in this location, or access denied, or "cannot create file".

I have edited these same files in these same locations on this same machine dozens of times without a problem before. This is something new that starting just this morning. System restore didn't help.

This is a Win7 HP PC and I'm the Owner/Administrator.
pjfarr
Found this helpful 0
Answer
pjfarr replied on

Reply

Turns out it was indeed tied to the UAC setting. Apparently.

I'd disabled UAC a long time ago. I do a lot of tweaking, so the constant warnings and permission issues got old fast. Having to click 4 times to delete something from the Start Menu? Seriously? (Right-click > delete > "Are you sure?" > "Yes" > "You need administrator privileges to make this change. Click 'continue' to complete the action' > "Continue"). Yeah, UAC was disabled pretty quickly.

Anyway, I checked the UAC setting to see if it had mysteriously reinstated itself (in that way Windows has of doing things like that). It was still off. I turned it on again, then off, then rebooted as per the usual routine and I'm now able to edit and save .ini's in their native folders once again without any hassle.

I'd looked at the UAC setting before, and seeing it was still off, moved on to try something else. I guess there was some sort of system hiccup that made Windows think it was on again, even though the slider was all the way down. Enabling it, disabling it, and rebooting fixed the issue.
Sheldon Cooper
Found this helpful 0
Sheldon Cooper replied on
1. On the Start menu, type notepad
2. Right-click the application’s shortcut, and then click Properties.
3. In the Properties dialog box, click the Compatibility tab.
4. Do one of the following:
  • To apply the setting to the currently logged-on user, select the Run This Program As An Administrator check box, and then click OK.
  • To apply the setting to all users on the computer and regardless of which shortcut is used to start the application, click Change Setting For All Users to display the Properties dialog box for the application’s .exe file, select the Run This Program As An Administrator check box, and then click OK twice.

Should fix the issue for you.

-^-Bazinga-^-
Frederik Long
Found this helpful 0
Frederik Long replied on
I have edited these same files in these same locations on this same machine dozens of times without a problem before. This is something new that starting just this morning. System restore didn't help.

This is a Win7 HP PC and I'm the Owner/Administrator.

What might these locations be?
pjfarr
Found this helpful 0
pjfarr replied on

Reply

I did think of going into the compatibility tab of notepad.exe to try changing the admin settings, but all the options on the compatibility tab are greyed out.

If I right click the notepad icon and choose "Run as administrator" I can open any .ini from the File menu, make changes, and then save it no problem. Thing is, I never had to do that before. I could just open the file normally, edit, and save.

So I think something's changed in my security settings.
pjfarr
Found this helpful 0
pjfarr replied on

Reply

Any sub folder of the C:\Program Files parent folder.

In Googling this, many people have said these files are protected by default, but I had no problem making modifications to them before this morning.
Frederik Long
Found this helpful 0
Frederik Long replied on

Reply

Any sub folder of the C:\Program Files parent folder.

In Googling this, many people have said these files are protected by default, but I had no problem making modifications to them before this morning.

This is a typical UAC (User Account Control) issue which can be resolved with the method posted by C.Kennedy. Another method is to turn off UAC (not recommended). It might have been turned off until yesterday.
pjfarr
Found this helpful 0
Answer
pjfarr replied on

Reply

Turns out it was indeed tied to the UAC setting. Apparently.

I'd disabled UAC a long time ago. I do a lot of tweaking, so the constant warnings and permission issues got old fast. Having to click 4 times to delete something from the Start Menu? Seriously? (Right-click > delete > "Are you sure?" > "Yes" > "You need administrator privileges to make this change. Click 'continue' to complete the action' > "Continue"). Yeah, UAC was disabled pretty quickly.

Anyway, I checked the UAC setting to see if it had mysteriously reinstated itself (in that way Windows has of doing things like that). It was still off. I turned it on again, then off, then rebooted as per the usual routine and I'm now able to edit and save .ini's in their native folders once again without any hassle.

I'd looked at the UAC setting before, and seeing it was still off, moved on to try something else. I guess there was some sort of system hiccup that made Windows think it was on again, even though the slider was all the way down. Enabling it, disabling it, and rebooting fixed the issue.