Jefphy
Had this question 50
Question
Jefphy asked on
| 42662 views

After XP to Windows 7 upgrade folder stuck in Read Only state.

Upgraded from XP Home to Win 7 Home Premium. Many folders are stuck in Read Only state. I have attempted the obvious: right click folder, uncheck Read Only and apply to all files/subfolders. Also have gone into Security and have given all users and groups Full Control to folder and all subfolders. Yet still remains in Read Only state. Only one user has been setup on computer and this user has full Administrative privileges.
Sue.Cat
Found this helpful 14
Answer
Sue.Cat replied on

Reply

Same problem for me, I tried everything suggested above, except WilliamJE's suggestion, and was still stuck. (I don't really understand WilliamJE's suggestion.)

I seem to have fixed the problem for me though by doing the following:

- open 'properties' on the highest level folder you want to change attributes

- click 'security' tab

- click 'advanced'

- click 'change permissions'

- click 'add'

- enter 'Everyone' in the 'enter the object name to select' dialog box

- click 'check names'

- click OK

- click 'full control' in the 'allow' column

- click OK

- click the box (turn on) 'replace all child object permissions with inheritable permissions from this object'

- click OK

- confirm any 'are you sure' type messages that pop up along the way

and you should be set! Whew!

 

 

Umesh P
Found this helpful 1
Umesh P replied on
Microsoft

Hi Jefphy,

Welcome to Microsoft Answers community.

Unlike the Read-only attribute for a file, the Read-only attribute for a folder is typically ignored by Windows, Windows components and accessories, and other programs. For example, you can delete, rename, and change a folder with the Read-only attribute by using Windows Explorer. The Read-only and System attributes is only used by Windows Explorer to determine whether the folder is a special folder, such as a system folder that has its view customized by Windows (for example, My Documents, Favorites, Fonts, Downloaded Program Files), or a folder that you customized by using the Customize tab of the folder's Properties dialog box. As a result, Windows Explorer does not allow you to view or change the Read-only or System attributes of folders.

 

To work around this problem, use the Attrib command at a command prompt (Cmd.exe) to view or to remove the Read-only or the System attributes of folders.

 

1.         Click Start, click Run, type cmd, and then press ENTER.

If the Run command is not listed on the Start menu, do the following:

Click Start, click All Programs, click Accessories, and then click Run.

2.         To view the syntax for the Attrib command, type attrib /? at the command prompt.

3.         To remove the Read-only attribute and to set the System attribute, use the following command:

attrib -r +s drive:\<path>\<foldername>

 

For example, to remove the Read-only attribute and to set the System attribute for the C:\Test folder, use the following command:

attrib -r +s c:\test

 

4.         Be aware that some programs may not operate correctly with folders for which the System attribute and the Read-only attribute are set. Therefore, use the following command to remove these attributes:

attrib -r -s drive:\<path>\<foldername>

 

For example, to remove both the Read-only and the System attributes from the C:\Test folder, use the following command:

attrib -r -s c:\test

For more information visit http://support.microsoft.com/kb/326549  

Hope this information is helpful.
Let me know if this worked.

Thanks and Regards:
Umesh P - Microsoft Support
Visit our Microsoft Answers Feedback Forum http://social.answers.microsoft.com/Forums/en-US/answersfeedback/threads/ and let us know what you think.

Jefphy
Found this helpful 1
Jefphy replied on

Reply

Thank you for the reply.  I have proceeded as you instructed but unfortunately it has not resolved the problem.  When I use the attrib command (attrib c:\kiosk -r /s) after some time it comes back with the message "File not found - C:\kiosk".  If I try to do an individual file (attrib -r swipe.txt) I get the message "Access denied - C:\kiosk\swipe.txt".

Again there is only one user and rights are set to Administrative.  Please let me know if you have any other ideas.  Thank you.
AHSIRT2
Found this helpful 1
AHSIRT2 replied on

Reply

I to have tried the above "solution" and have had no satisfaction.

Im the only user on my PC and i have Admin rights yet basically 100% of my folders and files are read only.

Something needs to be done about this as im sick of receiving msg's saying i don't have the privileges or the rights to complete the action
microjosh
Found this helpful 1
microjosh replied on

Reply

I have Windows 7 64 bit that I ran a clean install on.  Actually I'm dual booting with Windows XP.  I was able to save files with no problem for the first week.  Now all of a sudden I can't, and the reason is because of the read-only check box, and this is a serious issue.  I shouldn't have to do that above fix for every single folder I want to save files to, but every single folder has this problem.  I can't even save things to my desktop anymore because it is saying that the desktop folder is read-only.  Any help would be greatly appreciated.
Scuffs
Found this helpful 1
Scuffs replied on

Reply

I am also having this problem.  Windows 7 Professional 32bit, a single user set as administrator.  Every folder is set to read only, unchecking it does no good.  Unchecking it on individual files does no good.  I created a new user, and set that user as an administrator.  I can not remove read only attribute.  Has anyone found an answer to this yet?
TomParris
Found this helpful 1
TomParris replied on

Reply

I am having the same problem which is preventing me from file sharing and backing up. This is a serious problem and should be resolved by microsoft.

WORK AROUND: I have found using public folders is a work around but does NOT solve my problem as the problem has now migrated to my second hard drive which I use for back ups!!
carpemort
Found this helpful 1
carpemort replied on

Reply

i have fixed a lot of PCs and problems on them for friends, this is a problem i can't seem to solve, my external HDD has this problem aswell as the PC of my GF aswell as a laptop of a friend of mine, i have tried to change it as an administrator, in the command menu, even with 3 diffrent types of windows (XP pro, vista 32-bit premium, 7 64-bit ultimate)
only thing i know is that this problem spreads if you move a file with the problem into another folder, so to ppl who didn't know this yet (though i doubt no1 else noticed it) stop moving the files wich have the bug or whatever it is, and i'll just hope we get an answer soon, this really needs to be fixed soon
JimmyLuc
Found this helpful 0
JimmyLuc replied on

Reply

Have the same problem. Upgraded to 7 from Vista. Seems most prevalent when trying to save something to root of C. Taking ownership, giving yourself full control on C, removing read-only through DOS doesn't work.
Kyle1811
Found this helpful 0
Kyle1811 replied on

Reply

You might need to log in as root to change those settings... Look up how to enable built in administrator account and see if that helps. 

Rei1991
Found this helpful 1
Rei1991 replied on

Reply

I have the same problem with the read only on all my folders even new ones that i create. This issue needs to be fixed soon, I have tried the attrib -r +s c:\filepath\folder   command with several test folders in several locations and have yet to change anything on any of them. I have even tried the attrib -r -s  command as well with the same result... Someone come up with a solution asap please.
Previous Previous Page of 7 Next Next