widcommbug
Had this question 34
Question
widcommbug asked on
| 17936 views

Widcomm Uninstalltion wipes out the computer. New Virus or Windows Voulnerability.

VERY SERIOUS BUG/VULNERABILITY WIDCOMM BLUETOOTH SOFTWARE

Uninstalling Widcomm bluetooth software from control panel wipes out all data, programs and the boot sector on the computer.

I have tried to report this to microsoft but can't find out how. Please report this to the appropirate department.

I have windows 7 home premium. I tried to update my widcomm bluetooth software by downloading and installing the upgrade. The installation fails giving error 1935. After that the existing widcomm software becomes nonoperational. I tried to uninstall the widcomm bluetooth software from control panel the message "please wait while windows configures Bluetooth software". As it works all files from the hard drive are deleted, the desktop becomes empty, all open programs are deleted, all app data is deleted, the start menu becomes empty and finally it asks to reboot. After reboot the computer gives boot error message and does not boot up.

I had to install windows again to get the computer working. All data was lost. The anti virus was up to date and recent scans were all good. Windows was up to date. It appears that the error is from windows uninstaller some how going haywire when trying to remove widcomm bluetooth software. After restoring my computer I installed widcomm bluetooth software, copied the hard drive and tried to uninstall widcomm again. Results were exactly the same and I got screen shots from the beginning to the end. I have tried it on multiple computers with the same results (cloned the disk before)
andy_freak
Found this helpful 0
Answer
andy_freak replied on

Reply

Hi widcommbug,

yes, things are getting wild here...I don´t know why.

Maybe I can help you, here is what I did- and it worked:

1) I´ve deinstalled all versions of widcomm bluetooth software with the windows program deinstallation in the system tools.

2) I´ve restarted the PC

3) I´ve cleaned up the registry with a tool (I do not rely on any, I´ve used registry mechanic, which is the same as Norton Utillities 14- but it works more or less)

4) I´ve downloaded the latest version of widcomm bluethooth software here:

http://forum.gsmhosting.com/vbb/f237/widcomm-bluetooth-driver-6-4-0-670-a-1197332/ 

click on "deposit files", and you´ll get version 6.3.0.7000 of Lenovo widcomm bluetooth software which is the same

as original widcomm bluetooth.

5) Download it.

6) Extract it to a folder

7) Only use the file Broadcom_Bluetooth_6.4.0.670.exe out of the zip archive. Drop the rest.

8) If you´ll click on this .exe file you´ll only get some weird screen all filled up with ????, so you´ll have to use a different way:

9) Exctract Broadcom_Bluetooth_6.4.0.670.exe once again to a folder and then click on the file setup.exe

Then, the software will install correctly.

Well, this is weird, agreed. I found it out only a few trials. Remember, this software is leaked from Lenovo, but

it is the latest version I found, it is 100% Widcomm Bluetooth Software.

Here you have prove of what Widcomm is doing:

It does not provide the latest widcomm bluetooth software for free, but only for notebook manufacturers.

Widcomm doesn´t give a single hint on this policy on their homepage- private customers seem to be

unimportant for Widcomm- and still no amendment with the update bug in this software- really poor.

But no way to kid me.

BR

Andy

Shinmila H
Found this helpful 1
Shinmila H replied on

Hi widcommbug,

 

What is the make and model number of your computer?

 

Under normal circumstances this should happen.

 

 In general, error 1935 means that Microsoft Windows Installer encountered an error while trying to install assemblies to the Global Assembly Cache (GAC) or the Win32 GAC (WinSxS).

 

Before trying to reinstall, what I’d recommend for now is to remove all the registry entries of widcomm and test the behavior.

 

Method 1: Clear the Windows file system transaction log

 

a)   Open an Administrator command prompt. Here’s how:

                     i.       Go to Start  and type cmd.

                    ii.       Right-click on cmd and select "Run as Administrator".

                   iii.       Click "Allow" for the elevation prompt

b)   In the command prompt, type the command below:
fsutil resource setautoreset true C:\
This assumes that C: is the drive in which 7 is installed. If it is installed on another drive like D:, please change the drive letter appropriately.

c)    Reboot the system.

 

Method 2: Uninstall widcomm from the system.

 

The details below should help you remove the Widcomm drivers from your system.

 

a)   Go to Start > Run.

b)   Type the following commands one at a time without the quotes and press Enter.

"regsvr32 -u BtNeighborhood.dll"

"btstackserver.exe /unregserver"

 

Important: This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the windows help article below.

 

Back up the registry

http://windows.microsoft.com/en-us/windows7/Back-up-the-registry

 

c)    Go to start and type regedit.exe.

d)   Delete the WIDCOMM key from HKEY_CURRENT_USER and HKEY_LOCAL_MACHINE

e)   Delete "bt*.dll", "btcpl.cpl", and "bt*.manifest" from your system folder (this varies depending on which version of Windows you are using)

 

Clear the Windows file system transaction log before reinstallation.

 

Method 3: Reinstall widcomm software

 

Download the widcomm software from here and try the installation.

 

If the steps above produce the same result, get in touch with widcomm for further assistance.

Here’s the support link:http://www.broadcom.com/support/bluetooth/

 

Here’s where you can provide your feedback, bug or suggestions to Microsoft.

http://connect.microsoft.com/


Regards,

Shinmila H - Microsoft Support

Visit our Microsoft Answers Feedback Forum and let us know what you think.
widcommbug
Found this helpful 0
widcommbug replied on

Reply

Thanks for the answer. The issue is not installing the software. In fact after I did a new installation of Win 7 I was able to install widcomm without error 1935. But if I try to uninstall Widcomm Bluetooth Software from Control Panel the uninstall program wipes out the computer. I am not going to update or remove this program ever again as the same thing will happen unless someone figures out what is going on and fix it. I have no idea who is responsible but Microsoft should look into this to make sure its not from the OS and if not inform Broadcom to fix their program. I have emailed them and have not heard anything back. In fact their support email*** Email address is removed for privacy *** doesn't even work. Meanwhile I have found other reports of the same behavior onlinehttp://community.norton.com/t5/Norton-Internet-Security-Norton/Widcomm-uninstall-best-virus-ever/td-p/214662 . According to this post he installed the program without errors and when he tried to uninstall it his computer was wiped like mine. I wish I had seen this before I tried uninstall Widcomm from my computer

I strongly recommend that you test this on a computer and see what happens for your self. Find a compute with a bluetooth and Widcomm software, back up everything and uninstall Widcomm I have tested it on two separte computers (after copying the hard drive) and without even trying to update and had the same results. It is freightening and very srious. Please look into this.

ahjorth
Found this helpful 0
ahjorth replied on

Reply

So...... this happened to me too.

bluetooth wasn't working, so I unsinstalled WIDCOMM Bluetooth from the control panel.

 

Now I lost 90% of my files, programs and everything. This is ridiculous. I am interested to know if this is an issue with the WIDCOMM uninstaller or windows. I need to know who is supposed to pay me compensation if I can't recover the files. I did not install this program. It was installed when setting up my laptop. This is unacceptable.

SpiritX MS MVP
Found this helpful 0

Reply

Hi,

Be sure to logon with an ADMIN account and check C:\Users to see if the files are not still there
as they should be - where C: is the drive where the User Profiles are stored. Hopefully only the
User Accounts in the Registry were wiped out and not ALL the actual files.

If the files are still there (and even if not) try a System Restore back to before this happened.

How to Do a System Restore in Windows 7
http://www.sevenforums.com/tutorials/700-system-restore.html

---------------------------------------------------------------------------------------------------------------

This of course is a very serious issue and I would get the System Maker andf WidComm Support
involved.

Also contact Microsoft Support direct - upper right corner - email or phone
http://support.microsoft.com/ph/14019/en-us#tab0

Hope this helps.


Rob Brown - MS MVP - Windows Desktop Experience : Bicycle - Mark Twain said it right.
Rob Brown - Microsoft MVP - Windows Expert - Consumer : Bicycle - Mark Twain said it right.
ahjorth
Found this helpful 1
ahjorth replied on

Reply

The uninstall procedure took so long because it was actually deleting all the files on the computer. I managed to stop it before it totally destroyed everything, but about 50 hours of code that was worked on during the holiday got destroyed.

 

3 system restores did nothing. Was forced to use recovery software that only recovered about half of the lost files (but they were already backed up).

 

SpiritX MS MVP
Found this helpful 0

Reply

Hi,

Did it really delete files or did it corrupt the account so that some files could not be accessed?

Logon as an ADMIN and look in C:\Users  where C: is the drive where the User Profiles are
stored.

Tough anything is possible. something corrupting an account which makes some files unaccessible
or even seem to be deleted is much more likely than then actually being deleted.

Is it possible that malware as a role in this sort of weird occurrence?

 


Rob Brown - MS MVP - Windows Desktop Experience : Bicycle - Mark Twain said it right.
Rob Brown - Microsoft MVP - Windows Expert - Consumer : Bicycle - Mark Twain said it right.
ahjorth
Found this helpful 1
ahjorth replied on

Reply

So. Most things were deleted. Programs wouldn't load, and even their icons were gone. Folders were gone, and files were gone.

I did go into User/Name/Desktop and look there. The account used is an admin account. Also used safe mode to check.

I also checked the AppData folder and most was deleted there too.

 

I don't see how a malware could have done this. Uninstalled and installed often. The issue was, bluetooth wasn't working. So I downloaded an update from the Asus website. But first, I needed to remove the old bluetooth drivers. When I did, it was stuck at 1% for a very long time, like 30 minutes, and cancelling didn't work at all. So, when I also saw the HDD was working hard, I decided to shut down the process. Once the process was shut down, explorer.exe stopped working and restarted. Then when explorer.exe was running again, I noticed all the program icons were changed. I tried launching firefox, but it gave me a XUL error (like the files didn't exist).

 

After rebooting, I checked my folders, and noticed half of the folders were gone, and the folders were empty, except for the .js script files.

 

So I did a system restore. The label on the system restore was "Uninstalled WIDCOMM software (or something like that". It returned SOME of the program icons, but none of the programs actually functioned. Some files also came back, but only a very small fraction. I did another restore to the day before, when windows update created a restore point. Didn't help at all. And yet another restore 2 days previous, to no avail.

 

I also used two file recovery software tools, to try to get back the files. It managed to locate a bunch of deleted files and folders, but only from the letter H and down. So any folder starting on A-G was unrecoverable, and that is where, unfortunately all the files that were not backed up were.

 

So no, it was not an issue of corrupt files. The files were deleted. I suspect it is either a very badly coded uninstaller, that instead of uninstalling itself, uninstalls everything. (the WIDDCOM program itself still functioned after the files were deleted).

I ended up doing a fresh windows install and formatting the drive after exhausting all options to try and get the files back. It's a hassle to code it all again, but the only other thing I could do was to send the HDD in to a professional recovery company, and that would probably have cost more than the files were worth.

Emkay1001
Found this helpful 0
Emkay1001 replied on

I can confirm the same problem on Windows Vista Business 32-bit.

During the update of Widcomm (now Broadcom) software from 6.2.1.1500 to 6.2.1.2600 the error 1935 from Windows Installer pops up. When I attempted to uninstall the Widcomm software for a fresh install an "interesting" thing has happened. There was a lot of hard disk activity (on the NTFS MFT table according to Resource Monitor) and the next thing I know the hard disk is restored to a very early state from a year ago(!). All while system is running. Volume Shadow Copies at work? NTFS Transaction Log has a state from that long in time?
Yes, the data are gone from both user profile folders as well as from Program Files folder and other folders in root of C drive. And the system fails to boot up (BCD error), which can be fixed using the Windows PE. Run chkdsk c: /f and the only error it corrected was free space in NTFS bitmap. I couldn't get System Restore to work - it might have helped as it was taking a long time to restore files but in the end the "memory cannot be read" error comes up.
Brought the system back from a hard drive image with version 6.2.1.0100 of Bluetooth software and the upgrade to 6.2.1.2600 worked.
There were (most likely) no viruses or malware on the system (I'm very careful with that, don't really install much an use Virtual PC for the "risky" stuff), the hard disk, RAM and other components aren't faulty, the filesystem was "clean".

Most disturbing - it seems that a badly written uninstaller can do a sort of "all the way hard disk restore"?

PS. One important thing - data on other partitions are safe. So the only thing that was "wiped out" was the C drive. The D drive where I keep my Documents, Videos, Music wasn' touched.

SpiritX MS MVP
Found this helpful 0

Reply

Hi,

The way that uninstaller acts is the very essence of malware, whether the function is intended or
not. What a horribly written program which obviously was not checked at all by the authors.


Rob Brown - MS MVP - Windows Desktop Experience : Bicycle - Mark Twain said it right.
Rob Brown - Microsoft MVP - Windows Expert - Consumer : Bicycle - Mark Twain said it right.
ScienceOfThePS3
Found this helpful 2
ScienceOfThePS3 replied on

Yep, I too experienced the "delete everything on the hard drive" problem with trying to uninstall the Widcomm bluetooth drivers so I could update them.  All of my personal files from my user profile where wiped out.  All programs where wiped out, everything.  It seems like the only things that weren't deleted were running or protected system files.  The worst part about it was that I never backed anything up, and I was actually planning on doing one after fixing the bluetooth drivers.

Luckily, Windows 7 came to the rescue with Shadow Copies that it had of the entire drive from the day before (located under "Previous Versions" in the drive's properties dialog) and I was able to recover everything.  However, the damage was so severe that I didn't even bother to recover the entire drive except for my personal files.  I ended up reinstalling Windows 7, and have since got my computer back up and running again.

I have vowed to NEVER install the Widcomm bluetooth drivers until this issue gets fixed.  I now use Microsoft's generic bluetooth drivers which is actually sufficient enough for me since I used bluetooth for my keyboard and mouse, although I'm not quite sure on how I'll be able to get my bluetooth headset working without the drivers.

Let this serve as a warning for anyone that has the Widcomm drivers.  DO NOT attempt to uninstall them.  It will wipe your computer clean!   Microsoft and Broadcam really need to get their act together and fix this very serious issue.  I can smell the stench of lawsuits in the air...


Proud owner of a 60GB PS3!
Proud owner of a 60GB PS3!
Previous Previous Page of 10 Next Next