ScooterJack
Had this question 7
Question
ScooterJack asked on
| 164409 views

"You do not have permission to access" a computer - Windows 7

I now have 3 laptops in my house.  One is on Windows 7 (call it W7) and two are on Vista  (Call them V1 and V2).  On my Windows 7 computer, I can connect (through the network - all PCs are using the same Linksys wireless router) to V1 with no problem and see shared files, but I cannot connect to V2.  I get the message "you do not have permission to access \\PCName."  Now if I set up another user id on W7, I can access both V1 and V2.  I need to stick with my original user id if at all possible, as this is where I have already set up a lot of programs that I need for work.

Any ideas on what might be going on with my original user id?  It worked two weeks ago, although I've added a few programs since I last tried to access V2.  Thanks!
Malkeleah
Found this helpful 10
Answer
Malkeleah replied on
You can "stick with your original user"; just add it to the V2 machine. See Item C. below for details:

Problems sharing files between computers on a network are generally caused by 1) a misconfigured firewall or overlooked firewall (including a stateful firewall in a VPN); or 2) inadvertently running two firewalls such as the built-in Windows Firewall and a third-party firewall; and/or 3) not having identical user accounts and passwords on all Workgroup machines; 4) trying to create shares where the operating system does not permit it.

In Windows 7, go to Control Panel>All Control Panel Items>Network and Sharing Center. Click on "Change advanced sharing settings". You don't want to use Homegroup unless you have all Windows 7 machines. If you do and you want to use Homegroup, see Windows 7's Help & Support. Otherwise, in the Advanced Sharing:

Turn ON network discovery
Turn ON file and printer sharing
Turn ON sharing in the Public folder sharing section
Turn ON password protected sharing

A. Configure firewalls on all machines to allow the Local Area Network (LAN) traffic as trusted. With Windows Firewall, turning on Window's File and Printer Sharing as above will take care of this for you. If you aren't running a third-party firewall or have an antivirus/security program with its own firewall component, then you're fine.  With third-party firewalls, I usually configure the LAN allowance with an IP range. Ex. would be 192.168.1.0-192.168.1.254. Obviously you would substitute your correct subnet. Refer to any third party security program's Help or user forums for how to properly configure its firewall. Do not run more than one firewall. DO NOT TURN OFF FIREWALLS; CONFIGURE THEM CORRECTLY.

B. For ease of organization, put all computers in the same Workgroup. This is done from the System applet in Control Panel, Computer Name tab.

C. Create matching user accounts and passwords on all machines. You do not need to be logged into the same account on all machines and the passwords assigned to each user account can be different; the accounts/passwords just need to exist and match on all machines. DO NOT NEGLECT TO CREATE PASSWORDS, EVEN IF ONLY SIMPLE ONES . If you wish a machine to boot directly to the Desktop (into one particular user's account) for convenience, you can do this:

Start>Search box>type: netplwiz [enter]
Click on Continue (or supply an administrator's password) when prompted by UAC

Uncheck the option "Users must enter a user name and password to use this computer". Select a user account to automatically log on by clicking on the desired account to highlight it and then hit OK. Enter the correct password for that user account (if there is one) when prompted. Leave it blank if there is no password (null).

MS-MVP - Elephant Boy Computers - Don't Panic!
Elephant Boy Computers - Don't Panic!
CaptainFreedom
Found this helpful 1
CaptainFreedom replied on

Reply

You rock! I think I've looked at every possible solution to my Vista communicating with Windows 7 problem and zilch, nada worked. That is until I came across your post. Thanks!
czimmerman19
Found this helpful 1
czimmerman19 replied on

Reply

Was going nuts with a similar problem until I read this. The key was step C, creating matching user accounts. I did not have to turn on password protected sharing.  I don't understand why this is necessary, I have three windows seven machines all in the same homegroup. Very odd, thanks for the help.
coltow
Found this helpful 1
coltow replied on

Reply

Hi

I have been experiencing the same problems.  I have a laptop with windows 7 home and desktop with windows 7 ultimate.  when going to run - type \\computername\c$ i am prompted to enter a network password.  I have no passwords set up on either computer.  This is really bugging me.  I have carried out step C but don't appear to be having any luck.  both computers are on a workgroup with the same name.  They are both working off the same router.  All the sharing options are on.  

I don't know what else to try or maybe i have missed something that you may be able to point out
I would be grateful for any help

Thanks
Lin-Yin阿霖ㄚHsu
Found this helpful 0
Lin-Yin阿霖ㄚHsu replied on

Reply

Suodwi Gvygvyi "Tnsi vi  Cetuni" Ujqbuuji>

Suota geysuo uoi hii bugogri ? Pjhri envni trsi enleai eycvi uoi si kri ei cvazai qpji geygvyi ui fni !

Geni lii eoeoi tiduo dri cen tipeni tntui ...suoi eoi titi dri... eahulewluai dri gagvyi !

Enti tgvi eyi beadri gnger tni cvduo ...ewi titi dri cvi lewgeyi tei tuodri ...tsi eyi qndri eogoi lji ri ?

Hieoi geosi unqai uneyi eyi tnteai cvduo ...eykuii fnbeai butu tuni fjbei uouni lji ?

Eneni bufni eydji tunqun muosoi ...qnsi fnlua cvduo sq eahu lewluai !

Dasi uoi egen eyi mamai genzui qunkuni cvlewi geymeni ...stii qndri guotni cetui hixuai maeoi tewi qai ceni dri !

Qndri ewgeyi uobni hisi begewi zntuni tzai cenq vnvni hrsi...euoi uq q cenluai zumei fnsi drkr huaqua gewduo cege ceaceai ...tiguoi krei eycvi tiuoi dr letni far buq cesoi ...far tceni ujq cenzai drsn eoqi tasn gedri quabeai !

Gaceji ! eovzunea gage bugeni uoi dngii quji hrdri hrlni cedii vaquai titi tuaceri gensi dri leoquai~

Nicholas_W_
Found this helpful 0
Nicholas_W_ replied on

Reply

Hello Lin-Yin阿霖ㄚHsu,
 
Please select your language from the drop down list above to post your question in the language of your choice. The forum you posted in is for English only. If you do not find the desired language above, support options for additional international locations can be found by following the link below:
http://support.microsoft.com/common/international.aspx
 
Thanks

Nicholas_W_
Found this helpful 0
Nicholas_W_ replied on

Reply

Hello coltow

To avoid confusion and because this thread is old, please begin your own, new thread about YOUR specific problem and computer. State your current IE version and full Windows version (e.g., WinXP SP3; WinXP 64-bit SP2; Vista SP2; Vista 64-bit SP2; Win7; Win7 SP1; Win7 64-bit; Win7 64-bit SP1) in your first post. Thank you.
Radius001
Found this helpful 0
Radius001 replied on

Reply

I've tried so many things, because I've tried the solutions for errors related to this problem, like "error 0x80630203" and "error 1068", but you offered me the only working solution, being Step C!
Thank you very much!!
DONALDREYNOLDS
Found this helpful 0
DONALDREYNOLDS replied on

Reply

Holy carp! Thanks for step C! I've been tearing my hair out over this!
Domarius
Found this helpful 0
Domarius replied on

Reply

Wow, thanks Malkeleah!!

And thanks for nothing Windows!

Finally, after all this time and searching and giving up in the past...
Homegroup wasn't any use to me either because I use Hamachi and Homegroup messes up when you are joined to multiple networks (Microsoft even states this on their site)
Previous Previous Page of 2 Next Next