Kaixi
Had this question 3
Question
Kaixi asked on
| 6534 views

I can't open ports 5500, 5800 and 5900 in Windows Firewall

I added three rules for these ports in Advanced Settings but Windows Firewall is still blocking all the incoming connections through these ports. If I disable Windows Firewall, it's fine. BTW, I'm using Windows 7 x64 Pro.
Kaixi
Found this helpful 0
Answer
Kaixi replied on

Reply

I think I figured it out. I'm using Dyndns' OpenPort to test my ports. Theoretically, if a port is open i.e. not behind a firewall, the result should be either OPEN or REFUSED, but if a firewall is blocking the incoming connection, the result should be TIMED OUT.

The problem is that testing port 5500 with Win7 Firewall enabled always shows TIME OUT. But if I fire up UltraVNC Viewer (which listens behind this port) and test again, the port shows as OPEN.

So If I'm not mistaken, this means that basically, Win7 firewall is blocking any incoming connections from a specific port even if there's an exception rule when behind that port there's no app listening.

Samhrutha G
Found this helpful 0
Samhrutha G replied on
Microsoft

Hi Kaixi

 

Run the in-built troubleshooter and check if it helps:

Open the Incoming Connections troubleshooter by clicking the Start button, and then clicking Control Panel. In the search box, type troubleshooter, and then click Troubleshooting. Click View all, and then click Incoming Connections.

 

Link for reference: http://windows.microsoft.com/en-us/windows7/Allow-a-program-to-communicate-through-Windows-Firewall

 

Try Changing TCP/IP settings. Follow the steps listed in the below link: Change TCP/IP settings: http://windows.microsoft.com/en-US/windows7/Change-TCP-IP-settings

 

Firewall: frequently asked questions: http://windows.microsoft.com/en-US/windows7/Firewall-frequently-asked-questions

 

Thanks and Regards:

Samhrutha G S - Microsoft Support.

Visit our Microsoft Answers Feedback Forum and let us know what you think.

 

Kaixi
Found this helpful 0
Kaixi replied on

Reply

Thanks for answer, but the Troubleshooter is only for applications if I am not mistaken.

This is not about allowing applications thorough the firewall, but opening specific ports. To put it simple, I don't want Windows Firewall to monitor any activity on those 3 ports. I'm particularly interested in port 5500, it allows me to have UltraVNC Viewer in listen mode that will answer any incoming connections from that port.
Kaixi
Found this helpful 0
Answer
Kaixi replied on

Reply

I think I figured it out. I'm using Dyndns' OpenPort to test my ports. Theoretically, if a port is open i.e. not behind a firewall, the result should be either OPEN or REFUSED, but if a firewall is blocking the incoming connection, the result should be TIMED OUT.

The problem is that testing port 5500 with Win7 Firewall enabled always shows TIME OUT. But if I fire up UltraVNC Viewer (which listens behind this port) and test again, the port shows as OPEN.

So If I'm not mistaken, this means that basically, Win7 firewall is blocking any incoming connections from a specific port even if there's an exception rule when behind that port there's no app listening.

Samhrutha G
Found this helpful 0
Samhrutha G replied on
Microsoft

Reply

Hi Kaixi,

Glad to know issue is resolved. The steps would help other users having similar issue.

Regards,

Samhrutha

THRiLL KiLL
Found this helpful 0
THRiLL KiLL replied on

Reply

do you have a technet article that supports this? I am running into the same issues when try to remotely install a program. If the port is opened the install fails. IF the port is open, and the program is installed, and i reinstall it (remotely) , then the install works fine