jacko4000
Had this question 15
Question
jacko4000 asked on
| 54722 views

Windows could not start the Windows Search service on Local Computer

Ok so this is a big, messy and convoluted problem so please bear with me. Any help is greatly appreciated! I am starting to rip my hair out over this one...

I'm on Windows 7 Professional 64-bit
UAC is set at the 2nd lowest level

The other day I was having problems with the search box in the start bar. It was no longer finding excel or other office apps, and also it would not run basic commands like cmd, or notepad. Whenever I ran a command it would return an error like this (not exact as I no longer have the exact error message):

windows cannot find 'search:query=cmd'

I poked around a bit and tried to rebuild the index in Control Panel > Indexing Options. That did not work so I uninstalled Windows Search and reinstalled it. What i found now was that the Indexing service would not start anymore and if I manually tried to start it from services.msc I would get the following error:

Windows could not start the Windows Search service on Local Computer
Error 161: the specified path is invalid


The Event Log showed me this Application Error:

The gatherer service cannot be initialized.

Details:

The Temp folder is on a drive that is full or is inaccessible. Free up space on the drive or verify that you have write permission on the Temp folder. (HRESULT : 0x80070660) (0x80070660)

 


 
HELP!!!

rastamanxx
Found this helpful 2
Answer
rastamanxx replied on

Reply

Thank you Samhrutha.
Your proposed solution of editing the Registry is the only solution I've found so far that consistently works.
The only caveat I would note is that this fix results in windows search being completely reset to it's default settings.  Any search customizations what have been made by the user (e.g., user customizations to windows search indexing options) will be lost.

I am running Windows 7 Pro 64-bit, and on occasion have experienced the same error message (
windows cannot find 'search:query=XXX', where XXX is my search query) when attempting to initiate a search via the Windows start menu search box.

Only just recently, however, have I discovered another possible cause/fix to this issue.
More specifically, I have discovered that the windows search error occurs as a result of ADDING A NETWORK LOCATION to the local computer (e.g., via the "Add a network location" menu option which appears when clicking on the File menu in a windows explorer window displaying contents of the local computer (corresponding to the "COMPUTER" icon). The SYNC CENTER settings of my computer have been set to disable syncing of network or "offline" files, and I suspect that this setting is also part of the cause of the search error.

To fix this issue, one simply needs to tell windows search not to include the "network location" in the search index.  To do this, one needs to access the settings of the windows search INDEX LOCATIONS (via Indexing Options->Modify) and then uncheck the box corresponding to the network location (which on my computer begins as follows: oneindex://{s-1-5-21.....

After unchecking this box, click on OK button, and then CLOSE button to exit out of the Index Options windows.  After that the error message should hopefully not return.  If it does, try restarting the computer and test search again.

Hope this helps!!

:)

~rx

Samhrutha G
Found this helpful 5
Most Helpful Reply
Samhrutha G replied on
Microsoft

Hi jacko4000

 

I would suggest you to try these steps and check

 

Important: The instructions below contain steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information view the article in the Microsoft Knowledge Base: How to back up and restore the registry in Windows

 

i.           Click Windows + R (Opens run window)

 

ii.         Type regedit and press Enter.

 

 

iii.       In registry editor windows locate

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Search

 

iv.        In the right pane, right click on SetupCompletedSuccessfully and click on Modify.

 

NOTE: If SetupCompletedSuccessfully is not there, then in the right pane, right click on a empty area and click on ‘New’ select ‘DWORD (32 bit)’ Value and type SetupCompletedSuccessfully and press Enter.

 

v.          Type 0 and click on OK.

     NOTE: This is the number zero.

 

vi.        Close Regedit

 

vii.      Restart the computer

 

 

Thanks and Regards:

Samhrutha G S - Microsoft Support.

     Visit our Microsoft Answers Feedback Forum and let us know what you think.

Samhrutha G
Found this helpful 5
Samhrutha G replied on
Microsoft

Hi jacko4000

 

I would suggest you to try these steps and check

 

Important: The instructions below contain steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information view the article in the Microsoft Knowledge Base: How to back up and restore the registry in Windows

 

i.           Click Windows + R (Opens run window)

 

ii.         Type regedit and press Enter.

 

 

iii.       In registry editor windows locate

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Search

 

iv.        In the right pane, right click on SetupCompletedSuccessfully and click on Modify.

 

NOTE: If SetupCompletedSuccessfully is not there, then in the right pane, right click on a empty area and click on ‘New’ select ‘DWORD (32 bit)’ Value and type SetupCompletedSuccessfully and press Enter.

 

v.          Type 0 and click on OK.

     NOTE: This is the number zero.

 

vi.        Close Regedit

 

vii.      Restart the computer

 

 

Thanks and Regards:

Samhrutha G S - Microsoft Support.

     Visit our Microsoft Answers Feedback Forum and let us know what you think.

jacko4000
Found this helpful 0
jacko4000 replied on

Reply

Hi Samhrutha,

Thanks for the response. I've just had a look and the registry value was already set to 0.

However I did notice twos registry values "DataDirectory" & "DefaultDataDirectory" which were both set to %ProgramData%\Microsoft\Search\Data\.
So I opened up the permissions on this directory and attempted to start the Windows Serch service again.

I now get an error message saying that:
"The Windows Search service on Local Computer started and then stopped. Some services stop automatically if they are not in use by other services or programs."

Back to the Event Viewer I see a Warning in the Application events that says:

The Windows Search Service is starting up and attempting to remove the old search index {Reason: Full Index Reset}.

Followed by an Information event:

The Windows Search Service has successfully removed the old search index.

Followed by my original Error Event:

The gatherer service cannot be initialized.

Details:

The Temp folder is on a drive that is full or is inaccessible. Free up space on the drive or verify that you have write permission on the Temp folder. (HRESULT : 0x80070660) (0x80070660)


Any help is great appreciated. My start menu is practically useless at the moment and I am being forced to use Ctrl+R to run programs instead of typing them directly into the Start Search Bar (not the biggest issue but mildly annoying)



Thanks,
Jackson
rastamanxx
Found this helpful 2
Answer
rastamanxx replied on

Reply

Thank you Samhrutha.
Your proposed solution of editing the Registry is the only solution I've found so far that consistently works.
The only caveat I would note is that this fix results in windows search being completely reset to it's default settings.  Any search customizations what have been made by the user (e.g., user customizations to windows search indexing options) will be lost.

I am running Windows 7 Pro 64-bit, and on occasion have experienced the same error message (
windows cannot find 'search:query=XXX', where XXX is my search query) when attempting to initiate a search via the Windows start menu search box.

Only just recently, however, have I discovered another possible cause/fix to this issue.
More specifically, I have discovered that the windows search error occurs as a result of ADDING A NETWORK LOCATION to the local computer (e.g., via the "Add a network location" menu option which appears when clicking on the File menu in a windows explorer window displaying contents of the local computer (corresponding to the "COMPUTER" icon). The SYNC CENTER settings of my computer have been set to disable syncing of network or "offline" files, and I suspect that this setting is also part of the cause of the search error.

To fix this issue, one simply needs to tell windows search not to include the "network location" in the search index.  To do this, one needs to access the settings of the windows search INDEX LOCATIONS (via Indexing Options->Modify) and then uncheck the box corresponding to the network location (which on my computer begins as follows: oneindex://{s-1-5-21.....

After unchecking this box, click on OK button, and then CLOSE button to exit out of the Index Options windows.  After that the error message should hopefully not return.  If it does, try restarting the computer and test search again.

Hope this helps!!

:)

~rx

Samhrutha G
Found this helpful 0
Samhrutha G replied on
Microsoft

Reply

Hi rastamanxx,

 

Thank you for that fix, the steps will help other users facing similar issue. I will make a note of these steps.

 

Thanks and Regards:

Samhrutha G S - Microsoft Support.

aytoiu
Found this helpful 0
aytoiu replied on

Reply

thnks..

 

it works :)

HanusMaximus
Found this helpful 0
HanusMaximus replied on

Reply

Hey, I am having this same problem however when I try to turn on windows search I am told that access is denied. The account I am using how full admin control though. I think my indexing screwed up and turned off when I tried to index my external harddrive, either that or it never worked. Who knows, this laptop is only a month old but I can't turn the search feature on. I think maybe if I modify it to not include the external in indexing it would not mess up, but I can't even touch the modify button without enabling windows search, which is currently impossible. Any help?

jacko4000
Found this helpful 0
jacko4000 replied on

Reply

I eventually gave up on this one and just lived without a functional start bar Been planning to reinstall for months but haven't gotten around to it yet
Hai Bo
Found this helpful 0
Hai Bo replied on

Reply

I cannot start windows search as well, other searching functions are working well but I cannot search email items in Outlook 2007. When I try to start the windows search service manully by services.msc, an error " cannot start windows search, error 2 system cannot find files specified" appears. My system is windows 7 Ultimate X64.

Thanks.

pradeep_d
Found this helpful 2
pradeep_d replied on

Reply

Here is much simpler user level option, My son fixed this issue with the following on Windows 7 (32 bit Home)

Control Panel -> Programs -> Turn Windows features on or off -> Select Indexing Service and Windows Search

When promted reboot your machine..

 

PD
Hai Bo
Found this helpful 1
Hai Bo replied on

Reply

Thanks for your reply anyway. All I want to say is you have a smart and lucky son. The search function was enabled already and I have tried to reinstall them by Turn Windows features on or off but still failed.

Previous Previous Page of 3 Next Next