Jennifer Anns Group
Had this question 125
Question
Jennifer Anns Group asked on
| 396137 views

Problems with "File Association" in Windows 7 64-bit

Although I am able to go through the "regular" process to associate a program with an extension it doesn't work.  After going through the browse process and selecting the program it brings me back to the "open with" window.  The program I've selected does not appear in the "open with" window and it appears that it is simply ignoring me.

I've also tried the "Default Programs" route but wind up at the same "open with" window that still ignores me.

Suggestions?

-----------------------
[EDIT]
1) I've realized that this is probably not the proper forum for this question so feel free to ignore!
2) I've also realized that this may be an issue with associating extensions with non-64-bit programs and appears to be a non-issue if trying to associate with a 64-bit program... go figure.
Xandragnis
Found this helpful 255
Answer
Xandragnis replied on

Reply

After playing around a lil I think I've figured it out.. [for me at least..]

The program that you're pointing to isn't registered correctly.

In regedit: Navigate to Computer\HKEY_CLASSES_ROOT\Applications and find your .exe name. 
Navigate under its name to shell>open>command. In the Default change its location to the actual location of the executable, hit okay and then try and reassociate the file type as you normally would.

Let me know if that doesn't seem to work.


Syed N
Found this helpful 10
Syed N replied on
Microsoft Forum Moderator
Hi Jennifer Anns Group
 
Welcome to Windows 7 Forums

I require additional information in order to assist you better. 

What is the file extension you are trying to associate? 

A default program is the program that Windows uses when you open a particular type of file, such as a music file, an image, or a webpage. For example, if you have more than one web browser installed on your computer, you can choose one of them to be the default browser. 

Use this option to choose which programs you want Windows to use, by default. 

If a program does not show up in the list, you can make the program a default by using Set Associations.

    1.  Open Default Programs by clicking the Start button, and then clicking Default Programs.

    2.  Click Associate a file type or protocol with a program.

    3.  Click the file type or protocol that you want the program to act as the default for.

    4.  Click Change program.

    5.  Click the program that you want to use as the default for the file type you selected, or click the arrow next to

         Other   Programs to show additional programs. (If you don't see Other Programs, or your program
     is not listed,

         click Browse to find the program you want to use, and then click Open

    6.  Click OK

       For more details follow the link below:

http://windows.microsoft.com/en-us/windows7/Change-which-programs-Windows-uses-by-default 

 Try creating a new user account and check whether you have the same issue.

To create a user account

1.    To open User Accounts, click the Start button, click Control Panel, click User Accounts and Family Safety, and then click User Accounts.

2.    Click Manage another account. If you're prompted for an administrator password or confirmation, type the password or provide confirmation.

3.    Click Create a new account.

4.    Type the name you want to give the user account, click an account type, and then click Create Account.

 

For more information follow the link below:

http://windows.microsoft.com/en-us/Windows7/Create-a-user-account

 

If it works in the new user account, then the user account may be corrupted.

 

To fix the corrupted user profile you may refer the link below:

http://windows.microsoft.com/en-us/windows-vista/Fix-a-corrupted-user-profile

Hope this information is helpful.
 
Suresh G
Microsoft Answers Support Engineer
Visit our Microsoft Answers Feedback Forum and let us know what you think.

Christopher Pisz
Found this helpful 8
Christopher Pisz replied on

Reply

I have the exact same problem.
File association worked fine on XP. It does not on Windows 7. I believe what the OP meant by the usual steps was indeed what you listed as step 1-5
I had tried that and got the same result. After highlighting the desired executable in the browse window and hitting OK, you are taken back to the open with dialog and the executable you just selected does not appear there. Instead notepad is highlighted. Click ok and the file type is associated with notepad instead of the executable you just told it to associate with.

Please unmark your answer. It is not the answer.


Here is a copy of my technet forum post with the same issue:

It associates fine on XP. However, when I installed Windows 7 it refuses to associate. I cannot figure out how to fix the problem.

I have a shortcut to a .lbr file on my desktop
I have a .exe in my program files\company name\program name

I go to control panel->default programs->associate a file type or protocol with a program
scroll down to .lbr and highlight it
click change program...
browse to the .exe
double click the .exe

The open with window only shows notepad and if I hit OK it associates with notepad. The program I just browsed and clicked on doesn't show up, nor is the associattion made.

The program is just sits in its own directory. I believe it was developed without an installer. So, I can only assume associations do not work on 7 if programs didn't go through an entore install process. It is often you just have little executables that reside entirely in thier own directory that don't have installers.

How to get this association working?
Xandragnis
Found this helpful 2
Xandragnis replied on

Reply

I have the same issue, Christopher. Mine's a .mkv association - only happened after I moved the .exe from it's original location. I've attempted clearing the associations from the registry as I figured a possible corruption.

Still nada..

After trying to reassociate the file again and again, once you navigate to the .exe for it to execute through, it doesn't show the icon or program to chose that you've just navigated to.


Hmmmmm
Xandragnis
Found this helpful 0
Xandragnis replied on

Reply

Quick update.... 


Oddly enough, if the folder of the program I'm trying to use as the exe for the file type is on the Desktop, it will appear correctly. If it's in the root [C:] or "Program Files"  /  "Program Files (x86)" - it will not show up.. Strange, yes/no?


Xandragnis
Found this helpful 255
Answer
Xandragnis replied on

Reply

After playing around a lil I think I've figured it out.. [for me at least..]

The program that you're pointing to isn't registered correctly.

In regedit: Navigate to Computer\HKEY_CLASSES_ROOT\Applications and find your .exe name. 
Navigate under its name to shell>open>command. In the Default change its location to the actual location of the executable, hit okay and then try and reassociate the file type as you normally would.

Let me know if that doesn't seem to work.


jaydeem
Found this helpful 2
jaydeem replied on

Reply

Xandragnis helped us as well; the path to the application was not registered correctly for some reason.   Wonder if there is a way to check all the app paths in Computer\HKEY_CLASSES_ROOT\Applications rather than manually? Also running x64.  Thanks Xandragnis! Peace.
Dimante
Found this helpful 2
Dimante replied on

Reply

Xandragnis  helped us as well; the path to the application was not registered correctly for some reason.   Wonder if there is a way to check all the app paths in Computer\HKEY_CLASSES_ROOT\Applications rather than manually? Also running x64.  Thanks Xandragnis! Peace.
Actually this most often happens when you have an earlier version of the program and you upgrade.  Like from Photoshop 7 to Photoshop CS3.  The uninstaller does not remove the registry keys like it should.

-D-
Todd.E.Pullen
Found this helpful 1
Todd.E.Pullen replied on

Reply

Hello,  I am having the same problem as Jennifer.  I have Windows 7 64-bit, and I have already paid for a copy of Microsoft Word 2000 (also called WINWORD.EXE).  Naturally, I want to continue using the program I have, rather than down-grading to Microsoft Works, or paying another $147 for Microsoft Word 2007.  I have successfully installed Word 2000, and am able to open that program and use it.

Unfortunately, I cannot seem to associate DOC files with this program.  It does not appear in my list of Default Programs, and when I try to add that program to the list, it simply does not appear.  Windows 7 is ignoring Word 2000 (probably on purpose).  I have tried to manually associate the DOC files to Word 2000, and again, Windows 7 ignores the program and the list of available programs is still limited to Microsoft Works.

Now what do I do?!

Todd P.
Todd.E.Pullen
Found this helpful 0
Todd.E.Pullen replied on

Reply

I tried doing that for C:\Program Files (x86)\Microsoft Office\Office\WINWORD.EXE but it did not work.
Limnios
Found this helpful 0
Limnios replied on

Reply

I am having this issue with the the Endnote program that should open .enw files. I repaired the registry key as indicated above (and it was referring to the pre-upgraded version), but I still cannot get the file association to work. Could there be other registry keys that I need to fix? I have already tried a full uninstall/reinstall. Thanks for the help. 
Previous Previous Page of 21 Next Next