Lamargene
Had this question 178
Question
Lamargene asked on
| 236726 views

Taskbar does not Auto-hide all the time Windows 7

**Original Title**
Windows 7 taskbar won't consistantly autohide. After changing the properties to Autohide and clicking 'OK', it hides for a brief second then reappears. Other times it autohides as desired.

My taskbar autohide behaves in an erratic pattern.  When I have an alert, it autohides after resolving the alert, but other times it refuses to go away, even if I, once again, open the properties, uncheck autohide, recheck autohide, then click 'apply' and/or 'OK'. As I type this, the taskbar stubbornly remains!

Noel Carboni
Found this helpful 11
Answer
Noel Carboni replied on

Reply

In the "good old days" applicaitons would often un-hide the Taskbar so their notification icons could show an updated status and they could ensure it would be seen.  I think this method has fallen out of favor, but older applications that haven't been updated could still be sending the commands to the system to show the Taskbar.  Is it possible that you have an older app in the notification area that's affecting the Taskbar as described?

What notification area icons do you have (and what versions)?

For what it's worth, I just tried disabling Avast Pro 5.0 and it still allowed the Taskbar to auto-hide.

-Noel

Shinmila H
Found this helpful 6
Answer
Shinmila H replied on

Hi Lamargene,


Welcome to Microsoft Answers.

See that “Lock the Taskbar” is not enabled. If it is, you may disable it by right-clicking on taskbar and unchecking it.

Still the same behavior?

If such is the case, I’d recommend you to download Microsoft Security Essentials on your computer. This will make sure that any virus, spyware or other malicious software on the computer is wiped out completely. Also if the weird behavior is due to any one of those, running the essentials will fix it.

Download it from
http://www.microsoft.com/Security_Essentials/

Do you see any changes after running the essentials? Post back and let us know.



 

 

Regards,

Shinmila H - Microsoft Support

Visit our Microsoft Answers Feedback Forum and let us know what you think

nicolaj82
Found this helpful 66
Most Helpful Reply
nicolaj82 replied on

Reply

Sign me up for the same problem, and it's actually quite annoying, but i did find solutions on another forum posting the same issue, and a guy came up with this.

-----------------------------------
Most of the solution are really dumb. Do these people have jobs?
No wonder the US is #9.

Open Task Manager and Regedit.

++ on the Start Menu & select 'Exit Explorer'

In Regedit, navigate to:

[HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Explorer\Streams\Desktop]

delete the value named 'Toolbars'.

In Task Manager, select 'File' -> 'New Task' -> type 'explorer' to restart
the shell.

If that doesn't do the trick, repeat deleting 'TaskbarWinXP' as well. (I
can't test right now).

 

And it's reported by other users to have worked as intended, but i will say that i have not tried this solution.

-----------------------------------

I also found this which seems to explain what Shinmila H couldn't, why this happens.


And yes, i tried this solution, and it worked like i charm.

-----------------------------------
Often times Windows will refuse to hide because it mistakenly believes there is still a tooltip balloon open. (I see this a lot myself with APC's Powerchute Personal Edition.) Unfortunately the only way to get your taskbar to properly hide again (and I don't mean uncheck the "Keep the taskbar ontop of other widows" option for a quick fix) is to restart the machine so that Windows resets the tooltip balloon status. What a pain!

Thankfully through my inability to let it go and hatred for this problem I have written a file that will fix this! (Works great on my Vista machine!) All the program does is overwrite the phantom tooltip balloon and then clear the tooltip balloon and Tahdah!

The tooltip will stay up for 10 seconds so that you can read the info on it (just telling you what it does and how you can contact me if you have any problems). You can close this tooltip balloon like any other by clicking on it, or if you mouse over the program tray icon it will close itself instantly.

http://www.multiupload.com/94SQZ50YK0

And here is a pic of how it looks in action.

http://i44.tinypic.com/1hzzn.jpg


I really hope this helped.

Shinmila H
Found this helpful 6
Answer
Shinmila H replied on

Hi Lamargene,


Welcome to Microsoft Answers.

See that “Lock the Taskbar” is not enabled. If it is, you may disable it by right-clicking on taskbar and unchecking it.

Still the same behavior?

If such is the case, I’d recommend you to download Microsoft Security Essentials on your computer. This will make sure that any virus, spyware or other malicious software on the computer is wiped out completely. Also if the weird behavior is due to any one of those, running the essentials will fix it.

Download it from
http://www.microsoft.com/Security_Essentials/

Do you see any changes after running the essentials? Post back and let us know.



 

 

Regards,

Shinmila H - Microsoft Support

Visit our Microsoft Answers Feedback Forum and let us know what you think

Lamargene
Found this helpful 2
Lamargene replied on

Reply

Dear Shinmila H,

Thank you for your reply.  I disabled Avast Antivirus, which I have used since before I loaded Windows 7, downloaded and ran Microsoft Security Essentials, which found no issues. These actions created no change in the Taskbar behavior.  BTW, I had already deactivated the 'Lock the Taskbar' button.  When I pull up the Taskbar properties, uncheck the 'Autohide' button, check 'apply', then recheck the 'Autohide' button, then check 'apply', the taskbar disappears for just one second, then reappears to stay.  Later, it may autohide, but never does when I run Mozilla Thunderbird email server.

Regards,

Lamargene
robromano
Found this helpful 1
robromano replied on

Reply

I also have the exact same problem, and already have Microsoft Security Essentials. The taskbar still doesn't act consistently, and it's a real headache when using some websites or programs. i don't have any viruses or spyware, it's a sparkling new laptop. The feature hasn't worked out so far, including out of the box...I think I am just going to change the setting back so it's not supposed to hide and adjust the height of open windows so that I'm not blocked by the taskbar from clicking on stuff.
Bergur
Found this helpful 2
Bergur replied on

Reply

Same problem here.

It hides for a sec and then pops up and blocks a part of the screen. Other programs run under it and I can't get to these.

I too have Avast and am ATM running Essentials - but it doesn't seem to fix anything...

Oh well... I thought WIN7 would do miracles and I've been bragging about it to my wife and my brother, who are Mac users... Perhaps they are right, I ought to get a...no! MS please help us!
tc39
Found this helpful 2
tc39 replied on

Reply

Same here.Nothing works HELP MS.Win 7 is sold as the end all,but not so much.PLEASE HELP MS.
Adam Wood
Found this helpful 1
Adam Wood replied on

Reply

I am Also Having this same problem, even at the point where there are no applications running at all.. i have used Auto-Hide for years.. this definitely seems to be a bug.. This did not happen in the Beta or RC for me! This seems to have been happening possibly since the 25th where I received Update KB976098..

Don't disappear on us now Microsoft.. this is causing a real problem for some of us!
heyooh
Found this helpful 1
heyooh replied on
I'm having the EXACT issue.  I actually found this thread while searching for a solution.  I've tried multiple things, and it just seems to be a bug of some sort.  I really hope we get a solution quickly because this has been annoying me incessantly.  OH it just popped up again.
Alanmcclean17
Found this helpful 2
Alanmcclean17 replied on
I am having the same problem
Ron Hoffman
Found this helpful 3
Ron Hoffman replied on
Put me down for the same problem.  Is is really annoying when watching a movie full screen with the toolbar sitting at the bottom.
SPara
Found this helpful 14
SPara replied on

Reply

Microsoft - PLEASE WAKE UP.  This is a bug in Win 7.  When is it going to be fixed as it is extremely annoying and prevents you from accessing the bottom of many webpages which renders it USELESS!.
Previous Previous Page of 36 Next Next