JMcKelvey
Had this question 92
Question
JMcKelvey asked on
| 186419 views

Cannot change desktop background in Windows 7 Home Premium

I noticed that someone else had this problem.  Does anyone know how to fix it?
Fedupwiththebackground
Found this helpful 4
Answer
Fedupwiththebackground replied on
I drove my self crazy trying to remedy this dilema for two days. I finally downloaded a program from Stardock called Windows Blinds. That solved my problem.  
Ty the IT Guy
Found this helpful 72
Most Helpful Reply
Ty the IT Guy replied on

Reply

I put the following in the run command:

%USERPROFILE%\AppData\Roaming\Microsoft\Windows\Themes

then deleted the bad picture, then everything worked fine after that.  It was a corrupted picture.

Ramesh Srinivasan
Found this helpful 0
Ramesh Srinivasan replied on
Hi JMcKelvey.

What happens when you try to change the desktop background? Any errors, or is the option missing altogether?
Ramesh Srinivasan, Microsoft MVP [Windows Desktop Experience]
Ramesh Srinivasan
JMcKelvey
Found this helpful 3
JMcKelvey replied on

Reply

If I select a new desktop background, the button at the bottom doesn't say "Save Changes", it just says "OK" and when I click on "OK", it just goes back to whatever background it had originally.  I don't get any error messages.
Renjith-IT Specialist
Found this helpful 0
Renjith-IT Specialist replied on

Reply

http://www.withinwindows.com/2009/10/20/hp-and-stardock-team-up-to-ship-netbooks-with-custom-wallpaper-themes/ 
Try this:

1. Open the control panel and type "experience" into the search box. One of the options should be "Check the Windows Experience Index'. Click on that, and make sure your video score is higher than 3. If any are blank, you've never seen this screen before, or you've upgraded your video drivers since installing windows then click on Refresh Now and let it do its thing.

2. Now type "glass" into the search box at the top right corner of the control panel. Select "Change Windows Glass Colours" or "Enable or disable transparent glass on windows" - they both bring you to the same screen. Make sure that enable transparency is selected. This is also where you can pick eggplant or whatever.

3. Now right click on the task bar beside your icons, and pick properties. At the very bottom of the taskbar tab is a check box for aero peek. Turn it on if you want the previews for your windows when you move your curser over the icons. I believe this requires the newer style taskbar though, so if you've changed it to the old style it won't work.

If none of that is what your looking for, go back to the windows experience index page. On the left hand side there should be an option 'Adjust visual effects', this lets you manually choose animations. Aero Peek and transparency can also be activated from this menu.

Hope some of this helps!

RuffianUK
Found this helpful 1
RuffianUK replied on

Reply

I have the same issue. I upgraded my Windows 7 starter to Windows Home Premium on my netbook and all was working well. I could select themes from the personalized option and they would change instantly (including the theme desktop pic). A day later and now when i select a theme the Windows colour and sounds will change but not the desktop pic. The pic is just stuck on a landsacpe image i had selected the day before. There is no error message. No matter what picture i select for the desktop and save, it still just stays on the same pic. I have tried aero themes, basic themes, just changing the desktop background on its own - nothing will change the current background picture. Very odd - please help
Renjith-IT Specialist
Found this helpful 4
Renjith-IT Specialist replied on

Reply

Are you trying this way no?

Default location of Windows 7 wallpaper:

Windows 7 is come with some very nice default wallpapers. These wallpapers are really nic. The default Windows 7 wallpaper images are located at:

C:\Windows\Web\Wallpaper

If your operating system is located other than C drive then the default location is just changes with drive name. For example:

If your Windows 7 is installed in D partition of your hard disk, then the default location of Windows 7 wallpapers is:  D:\Windows\Web\Wallpaper


If your Windows 7 is installed in E partition of your hard disk, then the default location of Windows 7 wallpapers is:  E:\Windows\Web\Wallpaper

Steps to change Windows 7 desktop background

Step 1: Right-click on the empty space on Windows 7 desktop and click on Personalize option.

Step 2: Now, click on Desktpop Background link at the bottom of the windows.

Step 3: After the above steps, a new window will be opened. In this windwod, you will find several nice wallpapers. To choose any wallpaper, just click on any wallpaper and that wallpaper will be set for your desktop background. If you want to set other image as your default background, then click on Browse button and browse to your favourite image location and select that image.

Step 5: After selecting the image for your desktop background, click on Save changes button.

RuffianUK
Found this helpful 2
RuffianUK replied on

Reply

Thank you for your reply.

Yes thats exactly the process i am using, however after i have chosen and clicked on the desktop background i would like, and pressed 'save changes', the background does not change and remains the background it was before. As i said it worked when i first upgraded to windows home premium for the first day but hasn't since. The only chnage i can think of that i have made is that i installed the latest version of messenger which installed some msn live software.

Please advise?
Renjith-IT Specialist
Found this helpful 0
Renjith-IT Specialist replied on

Reply

Can you check with the Laptop vendors ....? Is it laptop no?


I hear that laptop vendor are doing some modifcation on windows 7 before selling (personalization part) just  check with your vendor customer care .and please confirm  here

Thanks
Renjith
RuffianUK
Found this helpful 0
RuffianUK replied on

Reply

Have checked and the vendor and they say they have not altered anything to the standard windows 7 installation


Fedupwiththebackground
Found this helpful 4
Answer
Fedupwiththebackground replied on
I drove my self crazy trying to remedy this dilema for two days. I finally downloaded a program from Stardock called Windows Blinds. That solved my problem.  
SharonMary
Found this helpful 8
SharonMary replied on

Hi JMcKelvey,

This is an old post, and I see that there have been some solutions proposed, so you may have already solved your problem. I don't see any reference anywhere to the model of computer you are using. It's not a Hewlett Packard by any chance is it? If so, there are a couple of proven solutions.

If you haven't solved your problem yet, and it is an HP, try this:

  • Step by step:

1.  Go to  http://www.hp.com/#Support

2.  Choose the Download drivers and software button under Step 1
3.  Under Step 2, enter your product name (e.g. pavilion 2022 ... be very careful as the I am sure the precise model is important.)
4.  Click on the link matching your PC model
5.  Choose Windows 7 operating system (assume you will be 32-bit) 
6.  Scroll down the list Select software and drivers and choose Wallpaper picture position enabler 

 

>> If you can't find your product name in 3. above then you can run the sp45575.exe fix:

 

 

>> If running an exe file blind scares you, you can read about the sp45575.exe here:

 


Sharon Roffey, QLD, Australia
Sharon Roffey
Queensland, Australia

Microsoft Community Contributor Award recipient
Previous Previous Page of 13 Next Next