J.Anderson
Had this question 6
Question
J.Anderson asked on
| 5724 views

Vista 64 bit

I am having a very strange problem with my computer. Up until last week everything was fine, then one day when clicking on my IE shortcut it wouldn't connect. I get a message that says, "Internet Explorer can not display the web page." My wireless connection was good, I could click on my Windows live mail shortcut and it would connect and get my mail. I went into the help and support section, clicked on troubleshooting and went into Repair IE. When I clicked that, I went straight to the web without any problems. I did the enable and disable add ons. Shortcut still wouldn't work. Went back to Repair IE and got back on the web and started getting messages that DirectX and Adobe Flash were not compatable with my system. I am thinking, "OK, they were yesterday and everyday before that until now." So, I started looking around in my accessories and system tools. I found that I have 2 Internet Explorer's listed in my accessories. One is just IE and one is IE 64 bit. I am not sure how come I have two of them listed, but the IE will not work, even though the file is iexplore.exe. The IE 64 bit will work and the file for it is also iexplore.exe. The only thing is running the 64 bit, now none of my add ons work. I checked Internet tools and enabled them, but I keep getting that they aren't compatable with 64 bit. I have no clue why all of a sudden my Explorer is running in 64 bit. Next, I did the restore, I went back 10 days, just to make sure I was restoring to a good point. When I restarted, my shortcut was back to my original IE (I had removed it and added the IE 64bit shortcut). The shortcut still didn't work. I looked in system tools and IE 64 bit wasn't listed anymore. Then Windows needed to do an update and when that was finished, the IE 64 bit listing in system tools was there again, along with the regular IE. I checked in task manager and it is saying I am running in 64 bit, I tried to do a browse and find my old IE, but there are a million things listed there and I don't know where to look. From what I am getting, Windows did an update and somehow switched me or is making my computer think it needs to run in 64 bit, instead of 32 bit. I looked in control panel and under the system it says, "64 bit can not be your default". Well, 64 bit is the only one listed...so how do I keep it from being my default?  I also can't click on links in my email as they go straight to the IE page of "not being able to display the web page." Has anyone else had this happen or know how the heck to put my computer back to the way it was? Thanks to anyone who can help! I also tried last night to do a disk defrag and 5 hours later it still hadn't stopped running. Any other time it was done in like 30 minutes.

Here are the specs on my computer.

Gateway DX4710-05
x64 base PC
Intel Core 2 quad CPU
Q 6600 @ 2.40 GHZ
2400 MHZ, 4 Core, 4 Logical processors
C:\windows system/32
Windows Vista Home Premium Service Pack 2
J.Anderson
Found this helpful 0
Answer
J.Anderson replied on
Best I could find yesterday was that I have some corrupt files that are associated with 32 bit.  I tried many different types of remedies that had been suggested from other sites and only one suggestion worked, I have switched to FireFox.  All web pages and add ons are now working again. Before I switched to FireFox, I did try a reinstall of IE8 and was told it wasn't compatiable with my system.  Funny considering I had been running IE8 for about 2 or 3 months already without any problems. Anyway, switching browsers did the trick for me.
David Vinod
Found this helpful 0
David Vinod replied on

Reply


Hi,

The reason why you have two versions of browser on 64bit machine is, most of the third party add-ons are not compatible with 64bit version of Internet explorer. Microsoft provides you an option of opening those websites which have add-ons that are not compatible with 64bit browser through 32bit version of Internet explorer browser on 64bit machine.

Here's the title of each and the exe's that are running on 64bit version of Windows Vista.
Internet Explorer

"C:\Program Files (x86)\Internet Explorer\iexplore.exe"

Internet Explorer (64-bit)

"C:\Program Files\Internet Explorer\iexplore.exe"

To make 32bit version of Internet explorer as your default browser.
1. Go to Control Panel / System and Maintenance / System / Advanced system settings

2. "System Properties" window pops out

3. Select "Advanced" tab

4. Press "Environment Variables" button

5. Look at "System variables" section and select variable "Path". The click "Edit"

6. Edit variable value so that you add a string (without quotes!)

"C:\Program Files (x86)\Internet Explorer\iexplore.exe;"

to the beginning of the content of the field (i.e. the original string). Notice the semicolon (;) at the end of the string which separates different entries!

Example: If the original string was

%SystemRoot%\system32;%SystemRoot%

 

then now it should be:

C:\Program Files (x86)\Internet Explorer;%SystemRoot%\system32;%SystemRoot%

7. Click OK several times and you are finnished setting your path.

8. Restart your Windows/computer for changes to take effect.

9. When Windows starts, any application that wants to run iexplore.exe (i.e. IE) will now run 32-bit version of IE.


Please let us know if you need any further assistance.

Regards,
Sreekanth
Microsoft Support
Visit our
Microsoft Answers Feedback Forum and let us know what you think.

 

J.Anderson
Found this helpful 1
J.Anderson replied on

Reply


Hi,

The reason why you have two versions of browser on 64bit machine is, most of the third party add-ons are not compatible with 64bit version of Internet explorer. Microsoft provides you an option of opening those websites which have add-ons that are not compatible with 64bit browser through 32bit version of Internet explorer browser on 64bit machine.

Here's the title of each and the exe's that are running on 64bit version of Windows Vista.
Internet Explorer

"C:\Program Files (x86)\Internet Explorer\iexplore.exe"

Internet Explorer (64-bit)

"C:\Program Files\Internet Explorer\iexplore.exe"

To make 32bit version of Internet explorer as your default browser.
1. Go to Control Panel / System and Maintenance / System / Advanced system settings

2. "System Properties" window pops out

3. Select "Advanced" tab

4. Press "Environment Variables" button

5. Look at "System variables" section and select variable "Path". The click "Edit"

6. Edit variable value so that you add a string (without quotes!)

"C:\Program Files (x86)\Internet Explorer\iexplore.exe;"

to the beginning of the content of the field (i.e. the original string). Notice the semicolon (;) at the end of the string which separates different entries!

Example: If the original string was

%SystemRoot%\system32;%SystemRoot%

 

then now it should be:

C:\Program Files (x86)\Internet Explorer;%SystemRoot%\system32;%SystemRoot%

7. Click OK several times and you are finnished setting your path.

8. Restart your Windows/computer for changes to take effect.

9. When Windows starts, any application that wants to run iexplore.exe (i.e. IE) will now run 32-bit version of IE.


Please let us know if you need any further assistance.

Regards,
Sreekanth
Microsoft Support
Visit our
Microsoft Answers Feedback Forum and let us know what you think.

 


Thank you for your answer, but it still didn't work.  Have any other suggestions??
MIKE RAV
Found this helpful 0
MIKE RAV replied on

Reply

Seams like I have the same problem, just happened last week.  did you ever find a fix?
MIKE RAV
Found this helpful 0
MIKE RAV replied on

Reply

Seams like i have the same problem.  Did you ever find a fix

nv Pahrump
Found this helpful 0
nv Pahrump replied on

Reply

Changed the path exactly as directed.  Still unable to access web pages.  Connected to web, have tried all prior remedies.  No new programs added.  Internet access dropped out after working fine for many months. 
IE8
HP Pavilion dv 7
Intel core 2 due cpu P7350 @ 2.00 GHz
memory 4.00 GB
64 - bit operating system
Vista Home Premium with service Pack 2

What is another fix or workaround?



David Vinod
Found this helpful 0
David Vinod replied on

Reply

Hi Nv Pahrump,

Try to optimize your browser, follow the steps mentioned in the article below.

How to optimize Internet Explorer
http://support.microsoft.com/default.aspx/kb/936213

Below are some more articles that you can refer.

Troubleshoot Internet connection problems
http://windows.microsoft.com/en-us/windows-vista/Troubleshoot-Internet-connection-problems

Tips for solving problems with Internet Explorer
http://windows.microsoft.com/en-us/windows-vista/Tips-for-solving-problems-with-Internet-Explorer

Regards
Sreekanth.

Molly mo
Found this helpful 0
Molly mo replied on

Reply

How did you re set the brower