Wissago
Had this question 18
Question
Wissago asked on
| 73624 views

Stopping security warnings on trusted sites

How do you stop "Do you want to view only the webpage content that was delivered securely?" on trusted sites?
David_O - Support Engineer
Found this helpful 21
Answer
David_O - Support Engineer replied on

Hello Wissago,

 

1.       Go to Tools-> Internet Options-> Security

2.       Select the Security tab

3.       Click the Custom Level button

4.       In the ‘Miscellaneous’ section change  Display mixed content to Enable

5.       Click Ok

Please reply and let us know if your issue is resolved or if you need further assistance.

 


David O
Microsoft Answers Support Engineer
Visit our and let us know what you think.
David O
Microsoft Answers Support Engineer
Visit our and let us know what you think.
vinod Sundarraj
Found this helpful 3
Answer
vinod Sundarraj replied on

Reply

Hi Wissago,

I am a support engineer in the Internet Explorer Core team at Microsoft. I am going to talk about a change in Internet Explorer 8.0 with respect to a setting related to security zone called “Display mixed content”.

Now to take you back in IE 7 when we go to an HTTPS page that has non-secure HTTP content we get to see a dialog box asking

“This page contains both secure and nonsecure items. Do you want to display the non secure items”

By clicking Yes, I will ask it to display the mixed content.

To Disable/ Enable/ Prompt the “Display Mixed Content”, click on Tools | Internet Options. In the Internet Options dialog, click the “Security” tab. Pick the zone that you want to change the setting for and click the “Custom Level” button. In the Settings area, scroll down to the “Miscellaneous” section and modify the area highlighted in the dialog show below.

..And the dialog which comes in IE 7

The reason for the warning is that you’re on an SSL-secured (https protocol) page that is attempting to load non-SSL (http protocol) content. Something to note is that the dialog does not prompt if you’re on an HTTP page and you request HTTPS URL.

Hypertext Transfer Protocol Secure (HTTPS) is an Application Layer protocol  that is a combination of HTTP and SSL (Secure Socket Layer) or TLS (Transport Layer Security).  HTTPS connections are used for secure transfer of data between the website and the client. Messages are secure since the HTTP message is encrypted via SSL or TLS and then sent on the network/internet. When the message is received by the addressed station, it decrypts the message.

The dialog was changed in IE 8 to encourage users to make the more secure choice by selecting ‘yes’.  Selecting ‘yes’ to the IE 7 dialog resulted in showing both secure and non-secure content.

Note:  Please consider the security implications outlined within the dialog before honoring the dialog request.  The Security dialog is being presented for your information and protection.

We changed the wording of the mixed content (The mixed content refers to HTTP and HTTPS content ) warning dialog to "Do you want to view only the web content that was delivered securely?" The buttons are "Yes/No".

If you want to display mixed content in IE 8 you should click "No". The previous versions of IE asked the user "Do you want to display the secure and non secure content?" You click "Yes" If you want to display mixed content.

Well, that’s all for today.  Thank you so much for you time!

Regards,

VINOD  S | Support Engineer – IE Core 

David_O - Support Engineer
Found this helpful 21
Answer
David_O - Support Engineer replied on

Hello Wissago,

 

1.       Go to Tools-> Internet Options-> Security

2.       Select the Security tab

3.       Click the Custom Level button

4.       In the ‘Miscellaneous’ section change  Display mixed content to Enable

5.       Click Ok

Please reply and let us know if your issue is resolved or if you need further assistance.

 


David O
Microsoft Answers Support Engineer
Visit our and let us know what you think.
David O
Microsoft Answers Support Engineer
Visit our and let us know what you think.
vinod Sundarraj
Found this helpful 3
Answer
vinod Sundarraj replied on

Reply

Hi Wissago,

I am a support engineer in the Internet Explorer Core team at Microsoft. I am going to talk about a change in Internet Explorer 8.0 with respect to a setting related to security zone called “Display mixed content”.

Now to take you back in IE 7 when we go to an HTTPS page that has non-secure HTTP content we get to see a dialog box asking

“This page contains both secure and nonsecure items. Do you want to display the non secure items”

By clicking Yes, I will ask it to display the mixed content.

To Disable/ Enable/ Prompt the “Display Mixed Content”, click on Tools | Internet Options. In the Internet Options dialog, click the “Security” tab. Pick the zone that you want to change the setting for and click the “Custom Level” button. In the Settings area, scroll down to the “Miscellaneous” section and modify the area highlighted in the dialog show below.

..And the dialog which comes in IE 7

The reason for the warning is that you’re on an SSL-secured (https protocol) page that is attempting to load non-SSL (http protocol) content. Something to note is that the dialog does not prompt if you’re on an HTTP page and you request HTTPS URL.

Hypertext Transfer Protocol Secure (HTTPS) is an Application Layer protocol  that is a combination of HTTP and SSL (Secure Socket Layer) or TLS (Transport Layer Security).  HTTPS connections are used for secure transfer of data between the website and the client. Messages are secure since the HTTP message is encrypted via SSL or TLS and then sent on the network/internet. When the message is received by the addressed station, it decrypts the message.

The dialog was changed in IE 8 to encourage users to make the more secure choice by selecting ‘yes’.  Selecting ‘yes’ to the IE 7 dialog resulted in showing both secure and non-secure content.

Note:  Please consider the security implications outlined within the dialog before honoring the dialog request.  The Security dialog is being presented for your information and protection.

We changed the wording of the mixed content (The mixed content refers to HTTP and HTTPS content ) warning dialog to "Do you want to view only the web content that was delivered securely?" The buttons are "Yes/No".

If you want to display mixed content in IE 8 you should click "No". The previous versions of IE asked the user "Do you want to display the secure and non secure content?" You click "Yes" If you want to display mixed content.

Well, that’s all for today.  Thank you so much for you time!

Regards,

VINOD  S | Support Engineer – IE Core 

JakubUrban
Found this helpful 2
JakubUrban replied on

Reply

Hi guys,
I have tested  this settings for several times and this does not work if you have setup the site in TRUSTED ZONE. At least no for Google Apps site, the warning is shown regardless of the settings. But after the setting has been changed fot INTERNET ZONE, the warning is not shown anymore.

For security reason I would like to use it just for TRUSTED ZONE, but it does not work so I had to degraded security for all pages.

Jakub Urban
c4andrei
Found this helpful 1
c4andrei replied on

Reply

Hi guys,
I have tested  this settings for several times and this does not work if you have setup the site in TRUSTED ZONE. At least no for Google Apps site, the warning is shown regardless of the settings. But after the setting has been changed fot INTERNET ZONE, the warning is not shown anymore.

For security reason I would like to use it just for TRUSTED ZONE, but it does not work so I had to degraded security for all pages.

Jakub Urban

Hello,
I can confirm this behavior as well: google mail in TRUSTED Zone, with Mixed Content enabled still brings up the warning. It does not feel right to me.

Thanks, Andrei
JakubUrban
Found this helpful 0
JakubUrban replied on

Reply

Hi, I have solved this issue > place this URL's into trusted sites and you will get rid off these issues:

cgi.gstatic.com
ssl.gstatic.com
gmodules.com
google.com

The reason is that the page is containing elements from other URL's, so you will also need to put these URL's into trusted zone. Try to view source code of the page and look for any http or https links. 

Warning> this can be a security hole, so consider what exact URL is really trusted.

Jakub Urban
V.K. Viswanathan
Found this helpful 6
V.K. Viswanathan replied on

Reply

Why do the people who make these products, in this day and age, assume that every person using a computer is an engineer?  I have a Ph.D. in Molecular Biology (so, I will not brook any nonsense from someone who dismisses dissenters as Idiots), and I have used computers extensively - but the operative term is "used".  Not "Fixed", not "written code" etc.  But I cannot, for the life of me, fathom why I have to attend to my computer like it is a bloody electronic pet.  I want it to just lie there unobtrusively, and do my bidding when I need it to.  Yes, it is possible, by and large.  I do not need 10 pop-up balloons to tell me that my USB drive was recognized.  I assume it will be.  And that it will just sit there quietly and be accessible when I need it. 

In this specific instance, if the warnings do not make sense to me, what kind of a security measure is it if the ultimate decision to enter a site is mine?  Repeatedly clicking on "allow" does not make it any safer - it only shifts the blame from the software makers to the end-user.  If I enter a site into the trusted list (okay, I grant that I need to be involved in some way to protect myself), in my particular case it was my University's email server, why do I get 10 identical warnings before I can access my email? 

So, my suggestions to fix this problem - Use Firefox.  Or, as I am getting more and more tempted, switch to Macs (For in that switch what other problems may come, When we have shuffled off this personal computer, Must give us pause: there's the respect. That makes calamity of our digitial dependence)

And while we are at it, Vista, some nerdy 20-year old kids school project, absolutely sucks.  And so does the complete revamping of the Office products.  IF someone wants to truly improve these things, here is a tip - talk to your savvy mom or grandmom and ask her about the difficulties she has with the computer (especially if you are not there every weekend to fix the darn thing).

V.K. Viswanathan

jcperl
Found this helpful 0
jcperl replied on

Reply

Hello,

I tried your "solution" in all security tabs BUT it does not work !!!

Thank you in advance for your help.

Best regards, Jean-Claude.

jc
Buckeye Fan
Found this helpful 0
Buckeye Fan replied on

Reply

This did not work for me.  My settings were already configured as described.
jcperl
Found this helpful 0
jcperl replied on

Reply

This did not work for me.  My settings were already configured as described.

try to disable the Digoo Toolbar if you have it (or other toolbars you would have, Google is OK !), this solves all my problems (also Google Labs for Google Agenda which did not work !!)

Best regards, Jean-Claude.
jc
dgb55bgd
Found this helpful 0
dgb55bgd replied on

Reply

Thank you for your help.  In the last few days I began receiving a warning everytime I tried to connect to the internet, "Do you want to view only the webpage content that was delivered securely".  This has never happened before either while connecting to the internet or while surfing the web.  Your answer got rid of the annoying warning.  By disabling the message could I get in trouble on other sites? Thanks again for your help!!
Previous Previous Page of 5 Next Next