picotron
Had this question 15
Question
picotron asked on
| 9772 views

mailto-links no longer working with Protected Mode: On after update from IE7 to IE8 - Vista Business, Outlook 2007

Hello!

I'm experiencing a problem since the update from IE7 to IE8: when I click on a mailto-Link instead of Office Outlook 2007 starting and opening a new mail I get the error message: Cannot start Microsoft Office Outlook (or similar, since my Office is german I translated the error message as good as I could).

This problem only occurs with IE8 and Protected Mode: On
That means:
- clicking on a mailto-URL in another application works fine (FireFox, Adobe Reader,...)
- uninstalling IE8 and working with IE7 works fine (with Protected Mode: On!)

My OS: Microsoft Windows Vista Business SP2 (32-Bit)
Mail client (set as default): Microsoft Office Outlook 2007


I tried resetting IE8 a couple of times but without success.

One special thing about my constellation: My Windows is english whereas my Office is german, but I think that should not be an issue.


Thanks for every help!

Regards,
Dominik

SpiritX MS MVP
Found this helpful 0
Hi,

Try reseting associations for IE and your Outlook.

How to Set Default Associations For a Program in Vista
http://www.vistax64.com/tutorials/83196-default-programs-program-default-associations.html

-------------------------------------------
In case you have something blocking :

Start - All Programs - Accessores - System Tools - IE with no Addons - does this work better?

IE - Tools - Internet Options - Advanced Tab - click Restore then click Reset - Apply / OK

IE - Tools - Internet Options - Security Tab -  click reset all zones to default - Apply / OK

Close and restart IE and/or IE with no addons

any better?

IE - Tools - Manage Addons (for sure disable SSV2 if it is there, this is no longer needed but Java still installs it
and it causes issues - you ever update Java go back in and disable it again.) Look for other possible problems.

Windows Defender - Tools - Software Explorer - look for issues with programs that do not look right. Permitted
are usually OK and "not permitted" are not always bad. If in doubt about a program ask about it here.

Could be a BHO - BHOremover - Free - standalone program, needs no install, download and run. All BHO's are
not bad - Toolbars are BHO's.
http://securityxploded.com/bhoremover.php

Startup Programs
http://www.vistax64.com/tutorials/79612-startup-programs-enable-disable.html

Also get Malwarebytes - free - use as scanner only. If you ever suspect malware UPDATE it and then run it as
a scanner.

http://www.malwarebytes.org/

Hope this helps.


Rob - Bicycle - Mark Twain said it right.
Rob Brown - Microsoft MVP - Windows Expert - Consumer : Bicycle - Mark Twain said it right.
picotron
Found this helpful 0
picotron replied on

Reply

Hi,

thanks for that quick reply.

Default Associations are set ("This program has all its defaults") - I clicked "Set this program as default" again anyway just to make sure...

I tried the General and Security Reset but with no luck.

I tried it without addons as well, but also no luck.

I suppose the other things would only make sense if the "Internet Explorer (no add-ons)" would have helped - right?


Any more ideas?


Thanks a lot!

Regards,
Dominik
SpiritX MS MVP
Found this helpful 0

Reply

There are settings in IE  that also affects NoAdd Ons as well....... so I would try the Restore and Reset.
And check the BHO's and so on.

There may also be settings in your email program about Hyperlinks.


Rob - Bicycle - Mark Twain said it right.
Rob Brown - Microsoft MVP - Windows Expert - Consumer : Bicycle - Mark Twain said it right.
picotron
Found this helpful 0
picotron replied on

Reply

Hi!


I did the restore and resets - didn't help.


The SSV2 was already disabled and the Software Explorer, BHO and startup-programs all didn't list anything suspicious.

Also Malwarebytes didn't find anything bad.


It really feels like this is some kind of IE8/Protected Mode-bug, since it is fine with IE7 and fine with Protected Mode: Off and fine with every other program using a mailto:-link.
But it can't be a general bug - maybe because of the language combination (Office in german and Windows in english)?


Thanks for help!


Regards,
Dominik
SpiritX MS MVP
Found this helpful 0

Reply

Yes that well could be the case. Look closely in your email program as I said it often
has hyperlink settings as does IE.

Check with the experts in Office Discussion Groups
http://www.microsoft.com/office/community/en-us/FlyoutOverview.mspx

Maybe other ideas here :

Discussions in microsoft.public.internetexplorer.general
http://www.microsoft.com/communities/newsgroups/list/en-us/default.aspx?dg=microsoft.public.internetexplorer.general&cat=en_us_28cca3eb-7037-4d4f-bde1-d8efee1f1420&lang=en&cr=us

Hope this helps.



Rob - Bicycle - Mark Twain said it right.
Rob Brown - Microsoft MVP - Windows Expert - Consumer : Bicycle - Mark Twain said it right.
picotron
Found this helpful 0
picotron replied on

Reply

Hi!

Thanks, I now made a double-post here, for everyone who wants to follow this discussion:
http://www.microsoft.com/communities/newsgroups/list/en-us/default.aspx?dg=microsoft.public.internetexplorer.general&mid=033a5913-b618-420b-a773-cb6dbd491347&sloc=en-us

Thanks for your help!

Regards,
Dominik
Robert Aldwinckle on forums
Found this helpful 0
Robert Aldwinckle on forums replied on

Hello!

I'm experiencing a problem since the update from IE7 to IE8: when I click on a mailto-Link instead of Office Outlook 2007 starting and opening a new mail I get the error message: Cannot start Microsoft Office Outlook (or similar, since my Office is german I translated the error message as good as I could).

This problem only occurs with IE8 and Protected Mode: On
That means:
- clicking on a mailto-URL in another application works fine (FireFox, Adobe Reader,...)
- uninstalling IE8 and working with IE7 works fine (with Protected Mode: On!)

My OS: Microsoft Windows Vista Business SP2 (32-Bit)
Mail client (set as default): Microsoft Office Outlook 2007


I tried resetting IE8 a couple of times but without success.

One special thing about my constellation: My Windows is english whereas my Office is german, but I think that should not be an issue.


Thanks for every help!

Regards,
Dominik


I doubt that this is an IE problem, more likely a security issue that you should ask your administrator about.

FWIW  I tried simulating your symptom by entering  mailto:  in an IE8 Address bar.
With Protected Mode: On  I get the following prompt:

<transcription partial>
A website wants to open web content using this program on your computer.

This program will open outside of Protected mode.  Internet Explorer's Protected mode helps protect your computer.   If you do not trust this website do not open this program.
</transcription>

There is also a checkbox on that prompt:  Do not show me the warning for this program again.

So, possible implications from all that are:  what happens if you check the box and decline the prompt at the same time?  Perhaps you would never see the prompt again but would see a message similar to what you are reporting?  Or, this seems to me to be an opportunity for an administrator to prevent you seeing the option in the first place and thus always seeing whatever it is that you would see by both checking the box and declining the prompt.   FWIW speculating about this is as far as I want to go with this testing because I'm not sure what I would have to do to get the prompt again.   ; )


HTH

Robert Aldwinckle
---
picotron
Found this helpful 0
picotron replied on

Reply

Hi Robert,

thanks for your answer!

This machine is not inside a domain and is only "administered" by myself - so there are no policies or anything like that.

But you point out something that I forgot to mention: IE7 asks me the question you are stating but IE8 doesn't - I tried both: always allowing it while having IE7 and also resetting everything before updating to IE8 - same result with both tries.


Any more ideas?

I tried to keep both threads sync: in the other one, somebody asked an interesting question: which was installed first: SP2 or IE8...maybe uninstalling SP2 will be the next step, but I'm not yet sure about the implications!


Thanks for every help!


Regards,
Dominik

SpiritX MS MVP
Found this helpful 0

Reply

Hi,

This is not a fix however they do allow workaround which might help.

Here are a couple of things to help.

1. Add Send Link by E-mail to the Command Bar

IE - Right Click Command Bar (where House - Full Screen - Tools and so on are) Customize - Add or Remove
Commands - from left menu ADD to Right Menu - Send Link by E-mail. This will call up your default E-mail
Client with the Link in the body of the message.

2. Add Snip-it to the Right Click Menu of IE.

E-Mail Selected Text in a Web Page Using Snip IT Add-on for Internet Explorer
http://www.winhelponline.com/blog/e-mail-selected-text-in-a-web-page-using-snip-it-add-on-for-internet-explorer/

The Send Using MailTo calls up your default E-mail client. You can add the others as desired.

I wonder if the issue is due to non-English versions? Could it be others or only German.

Hope you sort it out.

Rob - Bicycle - Mark Twain said it right.
Rob Brown - Microsoft MVP - Windows Expert - Consumer : Bicycle - Mark Twain said it right.
Robert Aldwinckle on forums
Found this helpful 0
Robert Aldwinckle on forums replied on

Reply

Hi Robert,

thanks for your answer!

This machine is not inside a domain and is only "administered" by myself - so there are no policies or anything like that.

But you point out something that I forgot to mention: IE7 asks me the question you are stating but IE8 doesn't - I tried both: always allowing it while having IE7 and also resetting everything before updating to IE8 - same result with both tries.


Any more ideas?

I tried to keep both threads sync: in the other one, somebody asked an interesting question: which was installed first: SP2 or IE8...maybe uninstalling SP2 will be the next step, but I'm not yet sure about the implications!


Thanks for every help!


Regards,
Dominik


Well then, you could be your own "guinea pig"--do the test that I don't want to do for you.  ; )
E.g. in your IE7 case you could check that "Don't show me this again" box while declining the prompt.
However, instead of just doing that to confirm my speculation about what would happen you could also
be running ProcMon to capture whatever registry changes that actually makes--assuming registry changes
would be all that it would do.  Then hopefully we would be able to find a way to reverse those changes
and thus have a way of converting your IE8 case back to its default condition, with a prompt and an unchecked option.

Oh.  I have just had a better idea.  Instead of tracing a change in IE7 we could first trace the IE8 case to see if that makes apparent the registry value that is inhibiting the prompt.  So then a simpler (but not necessarily complete) comparison of the two cases would be just to inspect both registries for that value name and the values that it has in each case.  Then perhaps it would be sufficient just to change that value in the IE8 case to match the value in the IE7 case?  As I hinted the only possible problem that I can see with this approach is that it might leave undone whatever else gets changed when the prompt is declined and kept as the default action (for the Don't show me option.)

Another possibility would be that these values are included in the set of values that get reset to defaults by RIES.  In that case at the expense of all the other changes the RIES makes you would avoid all the above uncertainty about zapping registry values speculatively.   ; )


HTH

Robert
---
Previous Previous Page of 5 Next Next